Closed Bug 1514569 Opened Last year Closed Last year

Crash in ?MOZ_CrashOOL@@YAXPEBDH0@Z.llvm.17376181610851201702

Categories

(Core :: Graphics: WebRender, defect, critical)

Unspecified
Windows 10
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 1509817

People

(Reporter: jseward, Unassigned)

Details

(Keywords: crash)

Crash Data

This bug was filed from the Socorro interface and is
report bp-3117c49a-f91b-4ec3-8695-266580181216.
=============================================================

This is topcrash #2 in the Windows nightly 20181213224257, with
37 crashes in around 10 different installations.

Top 10 frames of crashing thread:

0 xul.dll ?MOZ_CrashOOL@@YAXPEBDH0@Z.llvm.17376181610851201702 mfbt/Assertions.h:314
1 xul.dll GeckoCrashOOL toolkit/xre/nsAppRunner.cpp:5118
2 xul.dll static void gkrust_shared::panic_hook toolkit/library/rust/shared/lib.rs:234
3 xul.dll static void core::ops::function::Fn::call<fn /libcore/ops/function.rs:78
4 xul.dll static void std::panicking::rust_panic_with_hook /rustc/abe02cefd6cd1916df62ad7dc80161bea50b72e8/src/libstd/panicking.rs:480
5 xul.dll static <NoType> std::panicking::begin_panic<str*> /libstd/panicking.rs:410
6 xul.dll static unsigned __int64 webrender::device::gl::TextureUploader<u8>::upload<u8> gfx/wr/webrender/src/device/gl.rs:2899
7 xul.dll static void webrender::renderer::Renderer::update_texture_cache gfx/wr/webrender/src/renderer.rs:2817
8 xul.dll static union core::result::Result<webrender::renderer::RendererStats, alloc::vec::Vec<webrender::renderer::RendererError>> webrender::renderer::Renderer::render_impl gfx/wr/webrender/src/renderer.rs:2552
9 xul.dll bool webrender_bindings::bindings::wr_renderer_render gfx/webrender_bindings/src/bindings.rs:617

=============================================================
Flags: needinfo?(jmuizelaar)
Status: NEW → RESOLVED
Closed: Last year
Flags: needinfo?(jmuizelaar)
Resolution: --- → DUPLICATE
Duplicate of bug: 1509817
You need to log in before you can comment on or make changes to this bug.