Crash when clicking on page while page loading

VERIFIED DUPLICATE of bug 151568

Status

()

Core
Layout
--
critical
VERIFIED DUPLICATE of bug 151568
16 years ago
16 years ago

People

(Reporter: Olivier Cahagne, Assigned: Marc Attinasi)

Tracking

({crash})

Trunk
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
Build ID: 2002061204 on Win2k (trunk).

Crash is reproducible even if hard to trigger.
Steps to reproduce crash:
1. Load URL http://www.epita.fr:8000/~cahagn_o/test/
2. Click on 'Parent Directory',
3. Immediately keep on clicking fast around where you just clicked, could be on
the image (b4.jpg), the white background, etc.,
4. Mozilla consistently crashes.

Talkback ID: TB7297820Y.
(Reporter)

Updated

16 years ago
Keywords: crash, stackwanted
Whiteboard: Need TB7297820Y data

Comment 1

16 years ago
WFM with build 2002052306 under Windows ME.

Updated

16 years ago
QA Contact: petersen → moied
(Reporter)

Comment 2

16 years ago
also crashing build 2002061504 (trunk) on Linux: TB7388672K.
Related: bug 152116.
OS: Windows 2000 → All
Hardware: PC → All
Stack from that talkback:

nsGenericHTMLElement::HandleDOMEventForAnchors [nsGenericHTMLElement.cpp, line 1448]
nsHTMLLinkElement::HandleDOMEvent [nsHTMLLinkElement.cpp, line 364]
nsGenericDOMDataNode::HandleDOMEvent [nsGenericDOMDataNode.cpp, line 903]
PresShell::HandleEventInternal [nsPresShell.cpp, line 6170]
PresShell::HandleEvent [nsPresShell.cpp, line 6088]
nsViewManager::HandleEvent [nsViewManager.cpp, line 2085]
nsView::HandleEvent [nsView.cpp, line 306]
nsViewManager::DispatchEvent [nsViewManager.cpp, line 1896]
HandleEvent [nsView.cpp, line 83]
nsWindow::DispatchEvent [nsWindow.cpp, line 1031]
nsWindow::DispatchWindowEvent [nsWindow.cpp, line 1048]
nsWindow::DispatchMouseEvent [nsWindow.cpp, line 4912]
ChildWindow::DispatchMouseEvent [nsWindow.cpp, line 5167]
nsWindow::ProcessMessage [nsWindow.cpp, line 3756]
nsWindow::WindowProc [nsWindow.cpp, line 1293]
USER32.DLL + 0x2e98 (0x77e12e98)
USER32.DLL + 0x30e0 (0x77e130e0)
USER32.DLL + 0x5824 (0x77e15824)
nsAppShellService::Run [nsAppShellService.cpp, line 451]
main1 [nsAppRunner.cpp, line 1472]
main [nsAppRunner.cpp, line 1808]
WinMain [nsAppRunner.cpp, line 1826]
WinMainCRTStartup()
KERNEL32.DLL + 0x17d08 (0x77e97d08) 
*** Bug 152116 has been marked as a duplicate of this bug. ***
bryner, cvs blame says it's you....
Keywords: stackwanted
Whiteboard: Need TB7297820Y data
oh.  This is in fact already fixed.

*** This bug has been marked as a duplicate of 151568 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 7

16 years ago
Verified -
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.