Download Manager not showing toolbar in SeaMonkey 2.53

RESOLVED FIXED in SeaMonkey2.63

Status

enhancement
RESOLVED FIXED
5 months ago
5 months ago

People

(Reporter: frg, Assigned: frg)

Tracking

SeaMonkey 2.53 Branch
SeaMonkey2.63

SeaMonkey Tracking Flags

(seamonkey2.49esr unaffected, seamonkey2.53 affected, seamonkey2.57esr fixed, seamonkey2.60 wontfix, seamonkey2.63 fixed)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Assignee)

Description

5 months ago
I just noticed that along the way we seem to have lost the toolbar in the Download Manager. Probably because of a change in Gecko. It does not show in 2.53 but works fine in 2.57. It probably works in 2.57 because some toolbar bindings were moved to comm-central.
(Assignee)

Comment 1

5 months ago
Posted patch 1514729-dmtoolbar.patch (obsolete) — Splinter Review
Even if working in 2.57 we should specify to use a toolbar. I didn't find the bug which caused the different behaviour in Gecko 56.
Attachment #9031848 - Flags: review?(iann_bugzilla)
Attachment #9031848 - Flags: approval-comm-esr60?

Comment 2

5 months ago
Comment on attachment 9031848 [details] [diff] [review]
1514729-dmtoolbar.patch

a/r=me
Attachment #9031848 - Flags: review?(iann_bugzilla)
Attachment #9031848 - Flags: review+
Attachment #9031848 - Flags: approval-comm-esr60?
Attachment #9031848 - Flags: approval-comm-esr60+
(Assignee)

Comment 3

5 months ago
Was actually caused by bug 1514585. Services.ww.openWindow with a null argument behaves differently from an argument with params. Internally window.arguments is not set per mdn 
nsIWindowWatcher but beats me why the window is created differently. Seems to be documented nowhere.
Depends on: 1514585
(Assignee)

Comment 4

5 months ago
New version providing an empty arguments string. Only with toolbar=yes the window turned out to be not resizable and before adding another option just lets restore the previous state.
Attachment #9031848 - Attachment is obsolete: true
Attachment #9032138 - Flags: review?(iann_bugzilla)
Attachment #9032138 - Flags: approval-comm-esr60?

Comment 5

5 months ago
Comment on attachment 9032138 [details] [diff] [review]
1514729-dmtoolbar.patch

r/a=me
Attachment #9032138 - Flags: review?(iann_bugzilla)
Attachment #9032138 - Flags: review+
Attachment #9032138 - Flags: approval-comm-esr60?
Attachment #9032138 - Flags: approval-comm-esr60+

Comment 6

5 months ago
Pushed by frgrahl@gmx.net:
https://hg.mozilla.org/comm-central/rev/b794f9853ab5
Show the toolbar in the Download Manager. r=IanN
Status: ASSIGNED → RESOLVED
Last Resolved: 5 months ago
Resolution: --- → FIXED
(Assignee)

Updated

5 months ago
Target Milestone: Future → SeaMonkey2.63
You need to log in before you can comment on or make changes to this bug.