"onOK" should be "onAccept" in Color Picker for doubleclick color seletion

VERIFIED FIXED in mozilla1.0.1

Status

VERIFIED FIXED
17 years ago
14 years ago

People

(Reporter: neil, Assigned: cmanske)

Tracking

({polish, regression})

Trunk
mozilla1.0.1
x86
Windows 95
polish, regression

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [fixed in trunk][adt2 RTM][verified-trunk])

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
Steps to reproduce problem:
1. Open a colour picker e.g. Format/Text Colour
2. Double-click on a colour cell

Expected results: dialog closes

Actual results: JS error
(Reporter)

Comment 1

17 years ago
Created attachment 87492 [details] [diff] [review]
Proposed patch
(Reporter)

Comment 2

17 years ago
Oops, forgot to set owner :-(
Assignee: syd → cmanske
Keywords: patch, polish, review, ui

Updated

17 years ago
Attachment #87492 - Flags: review+

Comment 3

17 years ago
Comment on attachment 87492 [details] [diff] [review]
Proposed patch

r=brade
(Assignee)

Updated

17 years ago
Keywords: nsbeta1+
Whiteboard: [FIX IN HAND][need sr=][adt2 RTM]
(Assignee)

Comment 4

17 years ago
This was obviously caused by converting "onOk" methods to "onAccept" and the
doublclick handler wasn't changed.
Status: NEW → ASSIGNED
Keywords: regression
Summary: Error: onOK is not defined → "onOK" should be "onAccept" in Color Picker for doubleclick color seletion
Target Milestone: --- → mozilla1.0.1

Comment 5

17 years ago
Comment on attachment 87492 [details] [diff] [review]
Proposed patch

sr=alecf
Attachment #87492 - Flags: superreview+
(Assignee)

Comment 6

17 years ago
fixed in trunk
Nominating to be fixed in branch.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Keywords: adt1.0.1, mozilla1.0.1
Resolution: --- → FIXED
Whiteboard: [FIX IN HAND][need sr=][adt2 RTM] → [fixed in trunk][adt2 RTM]

Comment 7

17 years ago
verified on trunk 0617. 
Whiteboard: [fixed in trunk][adt2 RTM] → [fixed in trunk][adt2 RTM][verified-trunk]

Comment 8

17 years ago
adding adt1.0.1+.  Please get drivers approval before checking into the branch.
Keywords: adt1.0.1 → adt1.0.1+
(Assignee)

Comment 9

17 years ago
*** Bug 123790 has been marked as a duplicate of this bug. ***
Comment on attachment 87492 [details] [diff] [review]
Proposed patch

Approval granted for 1.0 branch checkin; please remove the mozilla1.0.1+
keyword when this is fixed and add the fixed 1.0.1 keyword.
Attachment #87492 - Flags: approval+

Comment 11

17 years ago
please checkin to the 1.0.1 branch. once there, remove the "mozilla1.0.1+"
keyword and add the "fixed1.0.1" keyword.
Keywords: mozilla1.0.1 → mozilla1.0.1+
(Assignee)

Comment 12

17 years ago
checked into mozilla1.0.1 branch
Keywords: mozilla1.0.1+ → fixed1.0.1

Comment 13

17 years ago
verified in 7/17 branch build.
Status: RESOLVED → VERIFIED
Keywords: verified1.0.1

Updated

17 years ago
Keywords: fixed1.0.1
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.