Console output doesn't stay stay scrolled to bottom

VERIFIED FIXED in Firefox 65

Status

defect
P1
critical
VERIFIED FIXED
7 months ago
7 months ago

People

(Reporter: Harald, Assigned: nchevobbe)

Tracking

({regression})

65 Branch
Firefox 66
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(firefox-esr60 unaffected, firefox64 unaffected, firefox65 verified, firefox66 verified)

Details

Attachments

(3 attachments, 2 obsolete attachments)

STR:
- Open https://nchevobbe.github.io/demo/console-test-app.html
- Click "Log Error" button until the console is filled, then some more

ER: Console output stays scrolled to bottom, always showing the last message.
AR: Scroll position isn't updated and position stays fixed at one position

Async resolution of stack traces doesn't update scroll position
Since the component renders asynchronously, consumers might
want to hook up to the actual first rendering.
We provide an `onRender` prop that will be called once, when
the component is ready.
Pushed by nchevobbe@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/209bdfcecdc9
Add an `onReady` prop to the SmartTrace component; r=bgrins.
https://hg.mozilla.org/integration/autoland/rev/d822219ea9bc
Keep console scrolled to bottom when rendering SmartTrace; r=bgrins.
Since the component renders asynchronously, consumers might
want to hook up to the actual first rendering.
We provide an `onRender` prop that will be called once, when
the component is ready.
Attachment #9032681 - Attachment is obsolete: true
forgot to push the fix I made locally …
Flags: needinfo?(nchevobbe)
Attachment #9032679 - Attachment is obsolete: true
Assignee: nobody → nchevobbe
Status: NEW → ASSIGNED
Pushed by nchevobbe@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/851d0b820ac2
Add an `onReady` prop to the SmartTrace component; r=bgrins.
https://hg.mozilla.org/integration/autoland/rev/0381e284d33b
Keep console scrolled to bottom when rendering SmartTrace; r=bgrins.
https://hg.mozilla.org/mozilla-central/rev/851d0b820ac2
https://hg.mozilla.org/mozilla-central/rev/0381e284d33b
Status: ASSIGNED → RESOLVED
Closed: 7 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 66
Comment on attachment 9032512 [details]
Bug 1514815 - Keep console scrolled to bottom when rendering SmartTrace; r=bgrins.

[Beta/Release Uplift Approval Request]

Feature/Bug causing the regression: Bug 1508549

User impact if declined: Console won't stay scrolled to the bottom if a stacktrace is logged at some point (might be an error message or a console.trace), which is not ideal because we want to talk about how we made stacktrace better in 65.

Is this code covered by automated tests?: Yes

Has the fix been verified in Nightly?: Yes

Needs manual test from QE?: Yes

If yes, steps to reproduce: 1. Go to https://nchevobbe.github.io/demo/console-test-app.html
2. Open the console
3. Click on the "Log Error" button in content multiple times, so the console output has a scrollbar
4. Click on the "Log Error" button again a few times

Expected result: 
The console should always stay scroll to the bottom.

List of other uplifts needed: other patch in the same bug

Risk to taking this patch: Low

Why is the change risky/not risky? (and alternatives if risky): Devtools only, thoroughly tested manually, has a mochitest

String changes made/needed:
Attachment #9032512 - Flags: approval-mozilla-beta?
Comment on attachment 9032488 [details]
Bug 1514815 - Add an `onReady` prop to the SmartTrace component; r=bgrins!.

[Beta/Release Uplift Approval Request]

Feature/Bug causing the regression: None

User impact if declined: see other patch uplift request

Is this code covered by automated tests?: Yes

Has the fix been verified in Nightly?: Yes

Needs manual test from QE?: Yes

If yes, steps to reproduce: 

List of other uplifts needed: None

Risk to taking this patch: Low

Why is the change risky/not risky? (and alternatives if risky): 

String changes made/needed:
Attachment #9032488 - Flags: approval-mozilla-beta?
Comment on attachment 9032488 [details]
Bug 1514815 - Add an `onReady` prop to the SmartTrace component; r=bgrins!.

[Triage Comment]
Ensures that the console stays scrolled to the bottom when a stacktrace is logged. Thanks for including new tests. Approved for 65.0b7.
Attachment #9032488 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Attachment #9032512 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
I could reproduce this issue on 
Version 	66.0a1
Build ID 	20181217000148


I verified this bug fix on latest Firefox Nightly 66.0a1 (2018-12-26)and the Firefox Beta 65.0b7 (Build ID 20181226223516) with Windows 7 (x64), Ubuntu 18.04 (x64) and macOS 10.13.6

Build ID 	20181226093642 	
User Agent 	Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:66.0) Gecko/20100101 Firefox/66.0


Build ID 	20181226215140
User Agent 	Mozilla/5.0 (Macintosh; Intel Mac OS X 10.13; rv:66.0) Gecko/20100101 Firefox/66.0


Build ID     20181226215140
User Agent     Mozilla/5.0 (X11; Linux x86_64; rv:66.0) Gecko/20100101 Firefox/66.0


Version 	65.0b7
Build ID 	20181226223516
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.