Saving message with the existing filename...fail...

RESOLVED WORKSFORME

Status

SeaMonkey
MailNews: Message Display
--
critical
RESOLVED WORKSFORME
16 years ago
10 years ago

People

(Reporter: Yeh You-Ying, Unassigned)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.1a) Gecko/20020611
BuildID:    2002061104 (1.1 alpha)

While saving a message with the filename which already existed in the specific
directory, saving window just does nothing.

Reproducible: Always
Steps to Reproduce:
1. Open MozillaMail
2. Save any message into file
3. Use the default filename, "message". (extension filename is .eml)
4. Save another message with the default name, "message". (extension filename is
.eml)
5. Nothing happens...looks like hung...

Actual Results:  Since the filename already existed in the directory, Mozilla
should prompt warnning
message to user.
(Reporter)

Comment 1

16 years ago
"Save Message As" window just does nothing, and it looks like hung.
We shoould press Ctrl+Alt+Del to kill Mozilla process.  :-(

Comment 2

16 years ago
works for me using commercial trunk
Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.1a) Gecko/20020611 
When i save a mesg as file it works. If i repeat the process
again, using same file name, I get a prompt that file exists
and do I want to replace it? If i say yes it will replace it,
if I say no it wont.
QA Contact: olgam → gchan
(Reporter)

Comment 3

16 years ago
Hello,

I'll attach the message (HTML style) that can reproduce this issue later.
I've also tested with simple text message. Simple text message will not occure
this problem.
It seems to happen with complex HTML style message.

Thanks 
(Reporter)

Comment 4

16 years ago
Created attachment 87602 [details]
This message is comprised by complex HTML, this can reproduce this issue, every time.

This attachment is the every-day e-paper that I subscribed.

Comment 5

16 years ago
Reporter,
are you using a imap or pop mail acnt?

I tried using your mesg that you attached, unfortunately
I couldn't reproduce it. I think because when you attach
the mesg to the bug, we leave gifs/html as just ascii text
so I am not getting the full effect of the mesg.

If you could take the mesg you are having problems with,
select it, right click->edit as new, and send it to my
email addresss, I can then test it that way.

I tried saving html mesgs, mesgs w/attachments, mesgs with html
files or web pages in them, and I had no problem. Evertime
I was prompted to see if I wanted to replace the previous file.

thanks.
(Reporter)

Comment 6

16 years ago
Hello,

I just email to you with your way.
The message was encoded with Chinese-Big5.
Hope you can get through it. :)
Any problem please inform me.

Thanks for your effort.

Comment 7

16 years ago
Reporter,
Tried your email mesg that you sent me. And I had no
problems saving it. I tried saving it, even though 
previous file exists, and I was prompted to replace
it and I did and it was saved.

I tried both an imap and pop account.

I used commercial trunk on win2k:
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.1a) Gecko/20020614

This works for me. Have you tried a new profile?
If you send a web page embeded in email mesg, can you save it ok?
(Reporter)

Comment 8

16 years ago
>I tried both an imap and pop account.

  My environment is Win98SE+ Mozilla 1.1a (20020611)+ pop account

>I used commercial trunk on win2k:
>Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.1a) Gecko/20020614

>This works for me. Have you tried a new profile?

 I 'll try to remove my profile...But if my memory is right, I did remove it before.
 There is something strang, I can get through it with simple HTML message and
pure text message.
 Just failed in complex HTML source, just as the one I sent to you. 

>If you send a web page embeded in email mesg, can you save it ok?

 Both things will be tried next Monday.
 Thanks again.  :-)
(Reporter)

Comment 9

16 years ago
About this issue, it also occures with 1.0 Final.
(Reporter)

Comment 10

16 years ago
About sending a webpage(http://www.kimo.com.tw) to myself and saving it, it's ok
here (Win98SE + 1.0 Final).
But I think that's different thing. Two message source are not the same.
(Reporter)

Comment 11

16 years ago
Here with Mozilla 1.0 Final, I have another experiment.

1. Select the message and click right button
2. Choose "Edit As New"
3. Send this "Edit-As-New" to myself
4. Get this message and save as file. (filename is message.eml)
5. Save again.
6. Mozilla seems to hang, but if I press Ctrl+Alt+Del, and kill this composing
process,
   the warnning message of "Save Message As" window pops up. It asks me to
rename or 
   overwrite.

PS. I did remove my profile before re-install Mozilla 1.0.
    I'll try this again with 1.1 Alpha (2002-06-11-04)
(Reporter)

Comment 12

16 years ago
Here with Mozilla 1.1 Alpha (2002-06-11-04), I have the same experiment as above.

1. Select the message and click right button
2. Choose "Edit As New"
3. Send this "Edit-As-New" to myself
4. Get this message and save as file. (filename is message.eml)
5. Save again.
6. Mozilla seems to hang, this time  if I press Ctrl+Alt+Del, and kill this
composing
    process,  no more the warnning message of "Save Message As" window.
    All MozillaMail processes are killed. The quick-lauch in the system tray is
still alive.

Comment 13

16 years ago
I was able to save this message after Gary forwarded it to me on a 06-17 branch
build on win98.  

Reassigning this bug 
Assignee: sspitzer → ducarroz

Comment 14

16 years ago
Reporter, I tried your steps in the first comment with mozilla 1.1 alpha
build  (20020611) on win2k and I was able to save the mesg fine.
I was prompted to replace the file and I did with no problems.

I tried doing your steps in comment 11 & comment 12 and I was unable
to send the file to myself. In both branch,trunk and Mozilla 1.1 alpha when
I send the file I encounter this mesg (which you don't):
 'Sending of message failed. Please verify that your Mail&Newsgroup settings
  are correct and try again'.

Maybe because I don't have correct international fonts? I can only forw
the msg as attachment successfully.

Marina, do you know of any bugs like this in International?



Comment 15

16 years ago
Created attachment 88153 [details]
message source of the email that is causing the problems

Comment 16

16 years ago
Gary, i tried to Save this message as .eml file and had no problem, saving twice
gave me a warning that i the file already exists. Could that be that this
particular web page makes ( that the reporter gets in a newsletter) had problems
with displayinh? Can i get a URL to see the web page? Cc'ing to Rui and Yuing.

Comment 17

16 years ago
here are Rui's comments: 
I tried it with the followings:
1. US7.0PR1 and 061808branch on EN Win98SE
2. JA7.0PR1 on JA Win2K+SP2
3. SC7.0PR1, 060508branch and 061808branch on SC WinXPpro
I could not reproduce the hang on them.

Comment 18

16 years ago
I can not reproduce it on N7.0PR1 on WinXP-SC neither.

Comment 19

16 years ago
I can reproduce the problem on my XP.
Below is the steps I followed:
1. Save reporter's the attachment (id=87602) as text file into mail "Local
Folders" directory.
2. Restart the browser.
3. Select the mail and save as eml file.
Sometimes browser hangs when I first time bring up Save as dialog, sometimes it
hangs when I bring it up the second time. I don't think it's i18n related since
save as .eml file just dump mail's rfc822 data. Cc'ed to Naoki.

Comment 20

16 years ago
Can reproduce with shirley's steps in comment 19.
Save as dialog appears, I click save button, nothing happens,
I bring up another window running, click back on save as window,
and I then see 'do you want replace the file message'..

I think we've proven 'Save message As' with existing filename
works. I think this might be a unique case?
(Reporter)

Updated

16 years ago
Keywords: mozilla1.0.1, mozilla1.1
Product: Browser → Seamonkey
Assignee: ducarroz → mail
QA Contact: grylchan → search

Comment 21

10 years ago
WFM using steps from comment 19 Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b3pre) Gecko/20081229 SeaMonkey/2.0a3pre
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.