Create Filter From for Subject broken in 65.0

RESOLVED FIXED in Thunderbird 66.0

Status

defect
RESOLVED FIXED
6 months ago
6 months ago

People

(Reporter: thee.chicago.wolf, Assigned: mkmelin)

Tracking

({regression})

Thunderbird 66.0
Dependency tree / graph

Thunderbird Tracking Flags

(thunderbird65 fixed, thunderbird66 fixed)

Details

Attachments

(1 attachment)

Reporter

Description

6 months ago
User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:56.0) Gecko/20100101 Firefox/56.0 SeaMonkey/2.53

Steps to reproduce:

I right-clicked on the subject of a message and tried to run "Create Filter From..." to create a new filter.


Actual results:

The normal pop-up to create a new filter did not display.


Expected results:

The pop-up to create a new filter should have opened up.

Error console shows:

TypeError: aHeaderNode is null[Learn More] msgHdrView.js:1598:7

CreateFilter chrome://messenger/content/msgHdrView.js:1598
oncommand chrome://messenger/content/messenger.xul:1

Been a few version since I tried to make a new filter but this was working recently. Will try against 64.0b4 and 63.0b tomorrow to see where/when it broke.
Reporter

Comment 1

6 months ago
Confirming that this bug was introduced in 65.0 around Nov 1st. I tested 64.0 and 63.0 and they bring up the Filter Rules dialogue box when "Create Filter From..." is chosen. I went back and tested with some CC builds and found this. Didn't use Mozgression but I'm sure an exact commit can be found with this info.

Last GOOD: 2018-10-31-10-04-38-comm-central https://hg.mozilla.org/comm-central/rev/0029fe1e56d7870fac39504a9c212775e2939f58
First BAD: 2018-11-01-15-04-44-comm-central https://hg.mozilla.org/comm-central/rev/182a1b088330a2d72310ae2561004d955571e236

Comment 2

6 months ago
Sorry, but those revisions don't exist. Click the links to see for yourself.

Looking at the time span, it's most likely caused by the de-XBL work in bug 1491698:
https://hg.mozilla.org/comm-central/rev/0363b1013217

Thanks for using Daily, the ride is very bumpy these days.
Blocks: 1491698
Flags: needinfo?(mkmelin+mozilla)
Flags: needinfo?(arshdkhn1)
Keywords: regression

Updated

6 months ago
Summary: Create Filter From... broken in 65.0b3 → Create Filter From... broken in 65.0

Comment 3

6 months ago
Also see bug 1512831. BTW, this works for me on a trunk build of TB 66 for From and To, but not subject.
Summary: Create Filter From... broken in 65.0 → Create Filter From for Subject broken in 65.0
Reporter

Comment 5

6 months ago
(In reply to Jorg K (GMT+1) from comment #3)
> Also see bug 1512831. BTW, this works for me on a trunk build of TB 66 for
> From and To, but not subject.

Thanks. Will check it out.

Comment 6

6 months ago
Yes, those source links are broken, bug 1460487 (or friends).
Reporter

Comment 7

6 months ago
NOTED! ☺
Assignee

Updated

6 months ago
Assignee: nobody → mkmelin+mozilla
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Flags: needinfo?(mkmelin+mozilla)
Assignee

Comment 8

6 months ago
If you're wondering about the querySelectorAll(".headerValue"), that is because for Sender, we couldn't find a headerName. It's all a big mess...
Attachment #9032377 - Flags: review?(arshdkhn1)
Comment on attachment 9032377 [details] [diff] [review]
bug1514951_filter_from_subject.patch

Review of attachment 9032377 [details] [diff] [review]:
-----------------------------------------------------------------

LGTM.
Attachment #9032377 - Flags: review?(arshdkhn1) → review+
Flags: needinfo?(arshdkhn1)

Comment 10

6 months ago
(I'll land it with a better commit message)
Keywords: checkin-needed
Target Milestone: --- → Thunderbird 66.0

Updated

6 months ago
Attachment #9032377 - Flags: approval-comm-beta+

Updated

6 months ago
Component: Untriaged → Message Reader UI

Comment 11

6 months ago
https://hg.mozilla.org/comm-central/rev/e27c47602ff5d5ec7e7b18aa233f43f22cef6d11
Fix filter creation from subject header. r=arshad

(Pulsebot on strike??)
Status: ASSIGNED → RESOLVED
Closed: 6 months ago
Keywords: checkin-needed
Resolution: --- → FIXED
Reporter

Comment 13

6 months ago
Confirming it's fixed in 65.0 build 4. Thanks everyone! Happy Holidays.
You need to log in before you can comment on or make changes to this bug.