Closed Bug 1514985 Opened 1 year ago Closed 1 year ago

'GetGraphicsResetStatus' warning after run

Categories

(Core :: Canvas: WebGL, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla66
Tracking Status
firefox-esr60 --- unaffected
firefox64 --- wontfix
firefox65 --- wontfix
firefox66 --- fixed

People

(Reporter: ogasidlo, Assigned: jgilbert)

References

Details

(Keywords: regression, Whiteboard: gfx-noted)

Attachments

(1 file)

STR:

1. `./mach run`
2. Get warning `Can't find symbol 'GetGraphicsResetStatus'`

Current tip is 451045:d65d6d242070
Component: about:debugging → General
Product: DevTools → Core
Summary: [remote-dbg-next] 'GetGraphicsResetStatus' warning after run → 'GetGraphicsResetStatus' warning after run
My guess is that this is a regression from bug 1492580. This warning is printed on macOS whenever a window is opened.

Jeff, can we stop printing this warning? I've seen multiple people mention it as a possible cause of some problem they were having, when in fact it was completely unrelated.
Blocks: 1492580
Flags: needinfo?(jgilbert)
Keywords: regression
Component: General → Canvas: WebGL

This is now hard-stopping browser startup (i.e. crash) on OSX Mojave:

Can't find symbol 'GetGraphicsResetStatus'.
Exiting due to channel error.

Setting severity to blocker accordingly. There's no workaround, it seems, but I do note that this must be a recent regression from the past few days.

Severity: normal → blocker
Summary: 'GetGraphicsResetStatus' warning after run → Crash with 'GetGraphicsResetStatus' message at startup

I'm running a local debug build, btw.

Backtrace for the crash, courtesy of Mike ( https://gist.github.com/mikedeboer/1338484f5bf49afc85360294d966721c ):

* thread #27, name = 'Compositor', stop reason = EXC_BAD_ACCESS (code=1, address=0x0)
  * frame #0: 0x0000000102139596 XUL`mozilla::ipc::MessageChannel::Send(IPC::Message*, IPC::Message*) [inlined] mozilla::ipc::MessageChannel::AssertWorkerThread(this=<unavailable>) const at MessageChannel.h:538 [opt]
    frame #1: 0x0000000102139585 XUL`mozilla::ipc::MessageChannel::Send(this=0x000000012369f4f8, aMsg=0x0000000122ecfdd0, aReply=0x00000001236a1400) at MessageChannel.cpp:1412 [opt]
    frame #2: 0x00000001021b7806 XUL`mozilla::layers::PCompositorBridgeChild::SendFlushRendering(this=0x00000001236a1400) at PCompositorBridgeChild.cpp:718 [opt]
    frame #3: 0x000000010292423b XUL`mozilla::layers::ClientLayerManager::FlushRendering(this=0x0000000123a3a8d0) at ClientLayerManager.cpp:608 [opt]
    frame #4: 0x00000001041c622a XUL`nsViewManager::Refresh(this=0x00000001201c2f80, aView=0x0000000120e6f180, aRegion=<unavailable>) at nsViewManager.cpp:337 [opt]
    frame #5: 0x00000001041c507f XUL`nsView::PaintWindow(nsIWidget*, mozilla::gfx::IntRegionTyped<mozilla::LayoutDevicePixel>) [inlined] nsViewManager::PaintWindow(this=<unavailable>, aWidget=<unavailable>, aRegion=<unavailable>) at nsViewManager.cpp:694 [opt]
    frame #6: 0x00000001041c500e XUL`nsView::PaintWindow(this=<unavailable>, aWidget=0x0000000120a7cc00, aRegion=nsView::LayoutDeviceIntRegion @ 0x0000700009670288) at nsView.cpp:995 [opt]
    frame #7: 0x0000000104208ce8 XUL`nsChildView::PaintWindow(this=0x0000000120a7cc00, aRegion=LayoutDeviceIntRegion @ 0x0000700009670338) at nsChildView.mm:1511 [opt]
    frame #8: 0x0000000104215536 XUL`::-[ChildView drawRect:](self=0x0000000120a2b230, _cmd=<unavailable>, aRect=(origin = (x = 0, y = 0), size = (width = 1280, height = 946))) at nsChildView.mm:3660 [opt]
    frame #9: 0x00007fff32df1258 AppKit`-[_NSOpenGLViewBackingLayer display] + 640
    frame #10: 0x00007fff400fd568 QuartzCore`CA::Layer::display_if_needed(CA::Transaction*) + 634
    frame #11: 0x00007fff400eb7b7 QuartzCore`CA::Context::commit_transaction(CA::Transaction*) + 319
    frame #12: 0x00007fff400eb088 QuartzCore`CA::Transaction::commit() + 576
    frame #13: 0x00007fff326c1b94 AppKit`NSPerformVisuallyAtomicChange + 154
    frame #14: 0x00007fff32a43cf1 AppKit`-[NSOpenGLContext setView:] + 99
    frame #15: 0x00000001042148fc XUL`::-[ChildView updateGLContext](self=0x0000000120a2b230, _cmd=<unavailable>) at nsChildView.mm:3553 [opt]
    frame #16: 0x000000010421439e XUL`::-[ChildView preRender:](self=0x0000000120a2b230, _cmd=<unavailable>, aGLContext=<unavailable>) at nsChildView.mm:3423 [opt]
    frame #17: 0x000000010420c551 XUL`nsChildView::PreRender(this=0x0000000120a7cc00, aContext=<unavailable>) at nsChildView.mm:2089 [opt]
    frame #18: 0x00000001029694cf XUL`mozilla::layers::LayerManagerComposite::Render(this=0x00000001210aa120, aInvalidRegion=0x0000700009671aa8, aOpaqueRegion=0x0000700009671a68) at LayerManagerComposite.cpp:858 [opt]
    frame #19: 0x0000000102968e7c XUL`mozilla::layers::LayerManagerComposite::UpdateAndRender(this=0x00000001210aa120) at LayerManagerComposite.cpp:517 [opt]
    frame #20: 0x000000010296829f XUL`mozilla::layers::LayerManagerComposite::EndTransaction(this=0x00000001210aa120, aTimeStamp=0x0000700009671b60, aFlags=END_DEFAULT) at LayerManagerComposite.cpp:440 [opt]
    frame #21: 0x0000000102981f12 XUL`mozilla::layers::CompositorBridgeParent::CompositeToTarget(this=0x00000001236a0c00, aId=<unavailable>, aTarget=0x0000000000000000, aRect=0x0000000000000000) at CompositorBridgeParent.cpp:1006 [opt]
    frame #22: 0x000000010298b375 XUL`mozilla::layers::CompositorVsyncScheduler::Composite(this=0x0000000123a3aa40, aId=(mId = 0), aVsyncTimestamp=<unavailable>) at CompositorVsyncScheduler.cpp:229 [opt]
    frame #23: 0x000000010299faef XUL`mozilla::detail::RunnableMethodImpl<mozilla::layers::CompositorVsyncScheduler*, void (mozilla::layers::CompositorVsyncScheduler::*)(mozilla::layers::BaseTransactionId<mozilla::VsyncIdType>, mozilla::TimeStamp), true, (mozilla::RunnableKind)1, mozilla::layers::BaseTransactionId<mozilla::VsyncIdType>, mozilla::TimeStamp>::Run() [inlined] decltype(o=<unavailable>, m=<unavailable>, args=<unavailable>).*fp0(Get<0ul, 1ul>(fp1).PassAsParameter())) mozilla::detail::RunnableMethodArguments<mozilla::layers::BaseTransactionId<mozilla::VsyncIdType>, mozilla::TimeStamp>::applyImpl<mozilla::layers::CompositorVsyncScheduler, void (mozilla::layers::CompositorVsyncScheduler::*)(mozilla::layers::BaseTransactionId<mozilla::VsyncIdType>, mozilla::TimeStamp), StoreCopyPassByConstLRef<mozilla::layers::BaseTransactionId<mozilla::VsyncIdType> >, StoreCopyPassByConstLRef<mozilla::TimeStamp>, 0ul, 1ul>(mozilla::layers::CompositorVsyncScheduler*, void (mozilla::layers::CompositorVsyncScheduler::*)(mozilla::layers::BaseTransactionId<mozilla::VsyncIdType>, mozilla::TimeStamp), mozilla::Tuple<StoreCopyPassByConstLRef<mozilla::layers::BaseTransactionId<mozilla::VsyncIdType> >, StoreCopyPassByConstLRef<mozilla::TimeStamp> >&, std::__1::integer_sequence<unsigned long, 0ul, 1ul>) at nsThreadUtils.h:1106 [opt]
    frame #24: 0x000000010299fad0 XUL`mozilla::detail::RunnableMethodImpl<mozilla::layers::CompositorVsyncScheduler*, void (mozilla::layers::CompositorVsyncScheduler::*)(mozilla::layers::BaseTransactionId<mozilla::VsyncIdType>, mozilla::TimeStamp), true, (mozilla::RunnableKind)1, mozilla::layers::BaseTransactionId<mozilla::VsyncIdType>, mozilla::TimeStamp>::Run() [inlined] _ZN7mozilla6detail23RunnableMethodArgumentsIJNS_6layers17BaseTransactionIdINS_11VsyncIdTypeEEENS_9TimeStampEEE5applyINS2_24CompositorVsyncSchedulerEMS9_FvS5_S6_EEEDTcl9applyImplfp_fp0_dtdefpT10mArgumentstlNSt3__116integer_sequenceImJLm0ELm1EEEEEEEPT_T0_(this=<unavailable>, o=<unavailable>, m=<unavailable>) at nsThreadUtils.h:1112 [opt]
    frame #25: 0x000000010299fad0 XUL`mozilla::detail::RunnableMethodImpl<mozilla::layers::CompositorVsyncScheduler*, void (mozilla::layers::CompositorVsyncScheduler::*)(mozilla::layers::BaseTransactionId<mozilla::VsyncIdType>, mozilla::TimeStamp), true, (mozilla::RunnableKind)1, mozilla::layers::BaseTransactionId<mozilla::VsyncIdType>, mozilla::TimeStamp>::Run(this=<unavailable>) at nsThreadUtils.h:1158 [opt]
    frame #26: 0x0000000102103365 XUL`MessageLoop::DoWork() [inlined] MessageLoop::RunTask(this=<unavailable>) at message_loop.cc:442 [opt]
    frame #27: 0x0000000102103355 XUL`MessageLoop::DoWork() [inlined] MessageLoop::DeferOrRunPendingTask(this=<unavailable>) at message_loop.cc:450 [opt]
    frame #28: 0x0000000102103349 XUL`MessageLoop::DoWork(this=0x0000700009671d60) at message_loop.cc:523 [opt]
    frame #29: 0x0000000102103d3a XUL`base::MessagePumpDefault::Run(this=0x00000001173b83d0, delegate=0x0000700009671d60) at message_pump_default.cc:35 [opt]
    frame #30: 0x0000000102102b39 XUL`MessageLoop::Run() [inlined] MessageLoop::RunInternal(this=<unavailable>) at message_loop.cc:315 [opt]
    frame #31: 0x0000000102102b2a XUL`MessageLoop::Run() [inlined] MessageLoop::RunHandler(this=<unavailable>) at message_loop.cc:308 [opt]
    frame #32: 0x0000000102102b2a XUL`MessageLoop::Run(this=<unavailable>) at message_loop.cc:290 [opt]
    frame #33: 0x000000010210cb57 XUL`base::Thread::ThreadMain(this=0x00000001173af100) at thread.cc:192 [opt]
    frame #34: 0x0000000102108dfa XUL`ThreadFunc(closure=<unavailable>) at platform_thread_posix.cc:40 [opt]
    frame #35: 0x00007fff6256c305 libsystem_pthread.dylib`_pthread_body + 126
    frame #36: 0x00007fff6256f26f libsystem_pthread.dylib`_pthread_start + 70
frame #37: 0x00007fff6256b415 libsystem_pthread.dylib`thread_start + 13

I updated the gist to contain backtraces for the CGContext* errors that attempt to draw on an invalid/ null context.

Looks like this is due to a bad merge on my project branch... a mozilla-central debug build is working on my machine, which means I'm still investigating.
Meanwhile I don't think that this warrants upping the severity of this bug anymore.

Severity: blocker → normal

I think this crash is bug 1515183, it is unrelated to the GetGraphicsResetStatus message.

Duplicate of this bug: 1520331
Status: NEW → RESOLVED
Closed: 1 year ago
Flags: needinfo?(jgilbert)
Resolution: --- → DUPLICATE
Duplicate of bug: 1515183
No longer blocks: 1492580
Assignee: nobody → jgilbert
Status: RESOLVED → REOPENED
Depends on: 1492580
Resolution: DUPLICATE → ---
Summary: Crash with 'GetGraphicsResetStatus' message at startup → 'GetGraphicsResetStatus' warning after run
Whiteboard: gfx-noted
Pushed by jgilbert@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/830639112fdb
Only warnOnFailure for non-optional groups. r=lsalzman
Status: REOPENED → RESOLVED
Closed: 1 year ago1 year ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla66
You need to log in before you can comment on or make changes to this bug.