Closed Bug 1515027 Opened 3 years ago Closed 2 years ago

Sign up on plug.dj is not working while TP is ON

Categories

(Web Compatibility :: Desktop, defect, P1)

Firefox 66
Desktop
Windows 10
defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1226498

People

(Reporter: ciprian, Unassigned)

References

(Blocks 1 open bug, )

Details

(Whiteboard: [tp-content] [tp-social])

User Story

facebook.com
gmail.com
gstatic.com
Environment:
Operating system: Windows 10 Pro
Firefox version: Firefox Nightly 66.0a1 (2018-12-17) (64-bit)

Prerequisites:
Enable Basic Tracking Protection

Steps to reproduce:
1. Navigate to: https://plug.dj/
2. Click the "SIGN UP NOW" button.
2. Observe the page.

Expected Behavior:
The "Sign Up Now!" pop-up box must be displayed.

Actual Behavior:
The pop-up box is missing.

Notes:
1. Screenshot link: http://prntscr.com/lwhhgp
2. The issue is reproducible for all the available buttons from the page(LOGIN, FIND A COMMUNITY)
This is related to `login` breakage #1470298

Looking at the devtools console, here are the blocked resources:

The resource at “https://www.google-analytics.com/analytics.js” was blocked because content blocking is enabled.[Learn More] plug.dj
The resource at “https://static.hotjar.com/c/hotjar-553331.js?sv=5” was blocked because content blocking is enabled.[Learn More] plug.dj
The resource at “https://connect.facebook.net/en_US/sdk.js” was blocked because content blocking is enabled.[Learn More] plug.dj

So these are the domains to test:
www.google-analytics.com
static.hotjar.com
connect.facebook.net

I opened the URL in a fresh browser profile (Firefox Nightly 66, uMatrix installed, normal mode) and loaded the page. The pop-up box was not displayed.

I disabled the Spoof Referrer option in uMatrix and then *WHITELISTED*:

facebook.com
facebook.net
google.com
gstatic.com

After this, the pop-up box was displayed.
The other resources didn't help.

Umatrix screenshot link: http://prntscr.com/lwhbyj

google.com / gstatic.com can be found in disconnect-blacklist.json list.
facebook.com / facebook.net can be found in disconnect-mapping.json list.
Product: Tech Evangelism → Web Compatibility

This is because the site expects the Facebook SDK to load, otherwise it silently breaks the whole sign-in function. So this is a dupe of bug 1226498.

Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1226498
You need to log in before you can comment on or make changes to this bug.