Closed Bug 1515099 Opened 2 years ago Closed 2 years ago

playback stalls after seek when using web audio media element source node

Categories

(Core :: Web Audio, defect, P1)

65 Branch
defect

Tracking

()

RESOLVED DUPLICATE of bug 1512958

People

(Reporter: thomas_jenkinson, Unassigned)

Details

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_14_2) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/71.0.3578.98 Safari/537.36

Steps to reproduce:

See https://tjenkinson.github.io/firefox-65-web-audio-stall/

We start playing audio using a media element source node. We then seek to 5 seconds.


Actual results:

Playback stalls.


Expected results:

Playback to continue from 5 seconds.
Component: Untriaged → Web Audio
Product: Firefox → Core
persons, can you have a look?
Severity: normal → critical
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(apehrson)
Priority: -- → P1
A fix is ready in bug 1512958 but it's triggering a frequent orange on try (bug 1505250). I'm beginning to lean towards disabling that test unless we get the blocker fixed today.
Status: NEW → RESOLVED
Closed: 2 years ago
Flags: needinfo?(apehrson)
Resolution: --- → DUPLICATE
Duplicate of bug: 1512958
You need to log in before you can comment on or make changes to this bug.