Closed Bug 1515116 Opened 9 months ago Closed 9 months ago

Remove all the useless destroy methods on fronts

Categories

(DevTools :: Framework, enhancement, P2)

enhancement

Tracking

(firefox66 fixed)

RESOLVED FIXED
Firefox 66
Tracking Status
firefox66 --- fixed

People

(Reporter: ochameau, Assigned: ochameau)

References

Details

(Whiteboard: dt-fission)

Attachments

(3 files)

Bug 1510949 introduced useless destroy method on many fronts, like this one:
https://searchfox.org/mozilla-central/rev/13788edbabb04d004e4a1ceff41d4de68a8320a2/devtools/shared/fronts/animation.js#32-34
  destroy() {
    super.destroy();
  }

We should remove all of them.
Assignee: nobody → poirot.alex
Duplicate of this bug: 1514790
Pushed by apoirot@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/1a4647e09ea9
Remove all useless destroy methods on Fronts. r=jdescottes
https://hg.mozilla.org/integration/autoland/rev/f0a67e0b5282
Remove all useless constructor methods on Fronts. r=jdescottes
https://hg.mozilla.org/integration/autoland/rev/7d4570696c85
Let Front's constructor set the actorID instead of doing it manually. r=jdescottes
You need to log in before you can comment on or make changes to this bug.