Closed Bug 1515301 Opened 6 years ago Closed 3 years ago

Drop down menu options are not displayed on www.comune.milano.it while TP is ON

Categories

(Web Compatibility :: Site Reports, defect, P3)

Firefox 66
Desktop
Windows 10
defect

Tracking

(Not tracked)

RESOLVED INCOMPLETE

People

(Reporter: ciprian, Unassigned)

References

(Blocks 1 open bug, )

Details

(Whiteboard: [tp-analytics])

User Story

adobetm.com
Environment:
Operating system: Windows 10 Pro
Firefox version: Firefox Nightly 66.0a1 (2018-12-18) (64-bit)

Prerequisites:
1. Enable Basic Tracking Protection
2. Create tourist or basic visitor profile. 

Steps to reproduce:
1. Navigate to: https://www.comune.milano.it/wps/myportal/ist/app/contattami?cdmLocale=it&PAGFROM=/wps/myportal/ist/it/servizi/tributi/Tributi_sugli_immobili/TASI/TASI&TIPO=CMIGR&CODDEST=RDZ%20CENTRALE%20ISTITUZIONALE
2. Login into account.
3. Reach a drop down menu box.
4. Click on the drop down arrow.
5. Observe the menu.


Expected Behavior:
The options corresponding to the selected menu must be displayed.

Actual Behavior:
The menu options are not displayed.

Notes:
1. Screenshot link: http://prntscr.com/lwxzbr
This is related to `trackingprotection` breakage #1101005

Looking at the devtools console, here are the blocked resources:
The resource at “https://assets.adobedtm.com/fd235021841d59990748b6f77f451cc2db6649ad/satelliteLib-2d346812c55dcf490db0ee6bb3d7c77351023f45.js” was blocked because content blocking is enabled.[Learn More] contattami

So these are the domains to test:
​assets.adobedtm.com

I opened the URL in a fresh browser profile (Firefox Nightly 66, uMatrix installed, normal mode) and loaded the page. After the login I selected a drop down menu box and the menu options were not available,

I disabled the Spoof Referrer option in uMatrix and then *WHITELISTED*:

​assets.adobedtm.com

After this, the drop down menu options were displayed.
The other resources didn't help.

Umatrix screenshot link: http://prntscr.com/lwy3gw

adobetm.com can be found in disconnect-blacklist.json list.

So in conclusion:
adobetm.com - Analytics = [tp-analytics]
Product: Tech Evangelism → Web Compatibility

Does this still reproduce, Ciprian? I was able to fill out the "log in without registering" form, but was never sent a confirmation email. I don't think I saw adobetm requests being blocked.

Flags: needinfo?(ciprian.ciocan)

I experience the same issue as you did, Tom.

I tried to proceed without registering but I did not receive any confirmation email.

When I initially filed the issue I was able to create a tourist account, but in the meantime, it looks that some things have changed and I am not able to find the option to log in using a tourist account.

Flags: needinfo?(ciprian.ciocan)

Alright, thanks. I'm going to leave this open for now since we can't quite confirm whether it's still a problem.

The layout has changed and we are not able to create a tourist account anymore, thus unable to verify the issue.
https://prnt.sc/zqp3qk

I found some drop-down menus on a page and they work correctly with ETP - Standard/Strict.
URL: https://www.comune.milano.it/servizi
https://prnt.sc/zqph4c

Tested with:
Browser / Version: Firefox Nightly 87.0a1 (2021-02-16)
Operating System: Windows 10 Pro

I'll close the issue.

Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → INVALID
Resolution: INVALID → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.