Closed Bug 1515411 Opened 9 months ago Closed 8 months ago

Disable Return to AMO for 65 Beta and Release

Categories

(Firefox :: Messaging System, defect, P1, critical)

defect

Tracking

()

VERIFIED FIXED
Firefox 66
Iteration:
66.2 - Dec 24 - Jan 6
Tracking Status
firefox64 --- unaffected
firefox65 blocking verified
firefox66 --- verified

People

(Reporter: tspurway, Assigned: andreio)

References

(Blocks 1 open bug)

Details

User Story

In a fresh Firefox profile. On OSX make sure this is launched from the Applications folder and not from the installer.


> in order to confirm RTAMO is enabled

1. enable `browser.newtabpage.activity-stream.asrouter.devtoolsEnabled`
2. set `browser.newtabpage.activity-stream.asrouter.providers.onboarding` to `{"id":"onboarding","type":"local","localProvider":"OnboardingMessageProvider","enabled":true,"exclude":[]}`
3. navigate to `about:newtab#asrouter` and scroll to the bottom
4. click `Force attribution`
5. navigate to `about:welcome` and confirm that the RTAMO message is shown

> in order to confirm RTAMO is disabled

6. set `browser.newtabpage.activity-stream.asrouter.providers.onboarding` to `{"id":"onboarding","type":"local","localProvider":"OnboardingMessageProvider","enabled":true,"exclude":["RETURN_TO_AMO_1"]}`
7. navigate to `about:welcome` and confirm that the FxA accounts page is shown and not RTAMO

Attachments

(1 file)

Please uplift a patch to disable Return to AMO for 65 Beta and Release.  Please don't land this in Nightly 66.

This is the contingency action for for bug #1513317
Assignee: khudson → andrei.br92
User Story: (updated)
User Story: (updated)
Severity: enhancement → critical
Iteration: 66.1 - Dec 10-23 → 66.2 - Dec 24 - Jan 6
Status: NEW → RESOLVED
Closed: 9 months ago
Resolution: --- → FIXED
Blocks: 1517867

Please nominate this for Beta approval when you get a chance.

Flags: needinfo?(andrei.br92)
User Story: (updated)
Flags: needinfo?(andrei.br92)
User Story: (updated)
This adds an `exclude` field in local providers that allows to exclude specific messages by ID.

An additional issue was found that still needs export, so setting this to affected until that it done.

Comment on attachment 9035328 [details]
Bug 1515411 - Disable Return to AMO for 65 Beta and Release

[Beta/Release Uplift Approval Request]

Feature/Bug causing the regression: Bug 1468680

User impact if declined: We want to prevent releasing this feature to the release population

Is this code covered by automated tests?: Yes

Has the fix been verified in Nightly?: Yes

Needs manual test from QE?: No

If yes, steps to reproduce: It has already been tested by QA

List of other uplifts needed: None

Risk to taking this patch: Low

Why is the change risky/not risky? (and alternatives if risky): Patch turns off a feature does not introduce any new functionality

String changes made/needed: n/a

Attachment #9035328 - Flags: approval-mozilla-beta?

Verified using macOS High Sierra 10.13.6 on Nightly (20190111093148), I can confirm the default value includes "exclude":["RETURN_TO_AMO_1"]} and while the default value is present, the user is taken to the FxA sign-on page. Please note that testing was only possible on macOS at this time.

(In reply to Kate Hudson :k88hudson from comment #5)

An additional issue was found that still needs export, so setting this to
affected until that it done.

Does this follow-up affect the Beta uplift as well?

Flags: needinfo?(khudson)

It looks like the attachment from comment 6 includes the followup fix https://github.com/mozilla/activity-stream/commit/0c46c2809ea18f6beb84c8cdf007ef566fccdda4

That commit is being exported in bug 1519303

Blocks: 1519303

I'd like QA to verify that this is disabled as expected in 65.0b11.

Status: RESOLVED → REOPENED
Flags: qe-verify+
Resolution: FIXED → ---
Target Milestone: Firefox 66 → ---

Comment on attachment 9035328 [details]
Bug 1515411 - Disable Return to AMO for 65 Beta and Release

[Triage Comment]
Turns off the Return to AMO feature for Firefox 65. Approved for 65.0b11.

Flags: needinfo?(khudson)
Attachment #9035328 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

Comment on attachment 9035328 [details]
Bug 1515411 - Disable Return to AMO for 65 Beta and Release

Actually, we should hold off on this until the Phabricator commit gets the official r+.

Attachment #9035328 - Flags: approval-mozilla-beta+ → approval-mozilla-beta?

Comment on attachment 9035328 [details]
Bug 1515411 - Disable Return to AMO for 65 Beta and Release

[Triage Comment]
Approved for 65.0b11.

Attachment #9035328 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

Verified for 65.0b11 using MacOS 10.13.6. Steps from the description have passed with no other issues found on MacOS. Testing on windows platform will be handled on Bug 1519396 once it has been fixed.

Status: REOPENED → RESOLVED
Closed: 9 months ago8 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 66
Status: RESOLVED → VERIFIED
Depends on: 1519396
Duplicate of this bug: 1513317
See Also: → 1524028
Component: Activity Streams: Newtab → Messaging System
You need to log in before you can comment on or make changes to this bug.