Intermittent leakcheck | gpu 9524 bytes leaked (APZUpdater, APZUpdater::UpdateHitTestingTree, AsyncPanZoomController, CompositorManagerParent, CondVar, ...)

RESOLVED FIXED in Firefox 66

Status

()

defect
P3
normal
RESOLVED FIXED
5 months ago
3 months ago

People

(Reporter: intermittent-bug-filer, Assigned: kats)

Tracking

({intermittent-failure})

unspecified
mozilla66
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox66 fixed)

Details

Attachments

(1 attachment)

Reporter

Description

5 months ago
treeherder
Filed by: apavel [at] mozilla.com

https://treeherder.mozilla.org/logviewer.html#?job_id=217997982&repo=autoland

https://queue.taskcluster.net/v1/task/ALuSWoWiRk-DS7zjWusHlg/runs/0/artifacts/public/logs/live_backing.log

https://hg.mozilla.org/mozilla-central/raw-file/tip/layout/tools/reftest/reftest-analyzer.xhtml#logurl=https://queue.taskcluster.net/v1/task/ALuSWoWiRk-DS7zjWusHlg/runs/0/artifacts/public/logs/live_backing.log&only_show_unexpected=1

22:40:34     INFO - TEST-START | /css/css-text/astral-bidi/cypriot-anti-ref.html
22:40:34     INFO - PID 6312 | 1545259234318	Marionette	INFO	Testing http://web-platform.test:8000/css/css-text/astral-bidi/cypriot-anti-ref.html != http://web-platform.test:8000/css/css-text/astral-bidi/cypriot.html
22:40:34     INFO - PID 6312 | ++DOMWINDOW == 11 (00000232D790C400) [pid = 4660] [serial = 11] [outer = 00000232D2970800]
22:40:34     INFO - PID 6312 | ++DOMWINDOW == 12 (00000232D7910800) [pid = 4660] [serial = 12] [outer = 00000232D2970800]
22:40:34     INFO - PID 6312 | 1545259234513	Marionette	INFO	No differences allowed
22:40:34     INFO - PID 6312 | 1545259234515	Marionette	INFO	Testing http://web-platform.test:8000/css/css-text/astral-bidi/cypriot.html == http://web-platform.test:8000/css/css-text/astral-bidi/cypriot-ref.html
22:40:34     INFO - PID 6312 | ++DOMWINDOW == 13 (00000232D790D400) [pid = 4660] [serial = 13] [outer = 00000232D2970800]
22:40:34     INFO - PID 6312 | ++DOMWINDOW == 14 (00000232D7914C00) [pid = 4660] [serial = 14] [outer = 00000232D2970800]
22:40:34     INFO - PID 6312 | 1545259234680	Marionette	INFO	No differences allowed
22:40:34     INFO - TEST-PASS | /css/css-text/astral-bidi/cypriot-anti-ref.html | took 419ms
22:40:36     INFO - nsTraceRefcnt::DumpStatistics: 344 entries
22:40:36     INFO - TEST-INFO | leakcheck | gpu leaked 1 APZUpdater
22:40:36     INFO - TEST-INFO | leakcheck | gpu leaked 1 APZUpdater::UpdateHitTestingTree
22:40:36     INFO - TEST-INFO | leakcheck | gpu leaked 2 AsyncPanZoomController
22:40:36     INFO - TEST-INFO | leakcheck | gpu leaked 2 CompositorManagerParent
22:40:36     INFO - TEST-INFO | leakcheck | gpu leaked 8 CondVar
22:40:36     INFO - TEST-INFO | leakcheck | gpu leaked 1 IAPZCTreeManager
22:40:36     INFO - TEST-INFO | leakcheck | gpu leaked 2 IPC::Channel
22:40:36     INFO - TEST-INFO | leakcheck | gpu leaked 2 ISurfaceAllocator
22:40:36     INFO - TEST-INFO | leakcheck | gpu leaked 1 InputQueue
22:40:36     INFO - TEST-INFO | leakcheck | gpu leaked 17 Mutex
22:40:36     INFO - TEST-INFO | leakcheck | gpu leaked 2 PCompositorBridgeParent
22:40:36     INFO - TEST-INFO | leakcheck | gpu leaked 2 PCompositorManagerParent
22:40:36     INFO - TEST-INFO | leakcheck | gpu leaked 2 RefCountedMonitor
22:40:36     INFO - TEST-INFO | leakcheck | gpu leaked 2 StoreRef
22:40:36     INFO - TEST-INFO | leakcheck | gpu leaked 2 WeakReference<PCompositorManagerParent
22:40:36     INFO - TEST-INFO | leakcheck | gpu leaked 11 ZoomConstraints
22:40:36     INFO - TEST-INFO | leakcheck | gpu leaked 2 ipc::MessageChannel
22:40:36     INFO - TEST-INFO | leakcheck | gpu leaked 2 ipc::MessageChannel::DispatchOnChannel
22:40:36     INFO - TEST-INFO | leakcheck | gpu leaked 35 nsTArray_base
22:40:36     INFO - TEST-UNEXPECTED-FAIL | leakcheck | gpu 9524 bytes leaked (APZUpdater, APZUpdater::UpdateHitTestingTree, AsyncPanZoomController, CompositorManagerParent, CondVar, ...)
22:40:36     INFO - 
22:40:36     INFO - leakcheck | Processing leak log file c:\users\task_1545257054\appdata\local\temp\tmpkok2pm.mozrunner\runtests_leaks_6140_rdd_pid2692.log
22:40:36     INFO - 
22:40:36     INFO - == BloatView: ALL (cumulative) LEAK AND BLOAT STATISTICS, rdd process 2692
22:40:36     INFO - 
22:40:36     INFO -      |<----------------Class--------------->|<-----Bytes------>|<----Objects---->|
22:40:36     INFO -      |                                      | Per-Inst   Leaked|   Total      Rem|
22:40:36     INFO -    0 |TOTAL                                 |       38        0|    1303        0|
22:40:36     INFO - 
22:40:36     INFO - nsTraceRefcnt::DumpStatistics: 96 entries
22:40:36     INFO - TEST-PASS | leakcheck | rdd no leaks detected!
22:40:36     INFO - leakcheck | Processing leak log file c:\users\task_1545257054\appdata\local\temp\tmpkok2pm.mozrunner\runtests_leaks_6140_tab_pid4660.log
Seems like issues on APZ stuff.
Component: CSS Parsing and Computation → Panning and Zooming
Duplicate of this bug: 1515470
Comment hidden (Intermittent Failures Robot)
Seems like a high failure rate, will look
Assignee: nobody → kats
Blocks: 1425592
Priority: P5 → P3
The leaks are always on the order of ~9500 bytes. Not sure what the root of the leak is but for now we can just set the leak threshold accordingly.

Comment 7

5 months ago
Pushed by kgupta@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/4fb222804956
Set a leak threshold for the gpu process on WR-enabled WPT tests. r=jmaher
Comment hidden (Intermittent Failures Robot)

Comment 9

5 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/4fb222804956
Status: NEW → RESOLVED
Last Resolved: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla66
Comment hidden (Intermittent Failures Robot)
See Also: → 1517128
See Also: 1517128
You need to log in before you can comment on or make changes to this bug.