doctype dtd processes onsubmit event inconsistently

VERIFIED DUPLICATE of bug 155453

Status

()

VERIFIED DUPLICATE of bug 155453
17 years ago
16 years ago

People

(Reporter: aspeitia, Assigned: joki)

Tracking

Trunk
PowerPC
Mac System 9.x
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
In mozilla build 2002052917 (1.0 release) the test link on page:

http://macwebdev.sells.com/websites/test_mozilla/test_onsubmit.html

submits ok.

but on mozilla 1.1a it does not submit at all.

I narrowed it down to the doctype definition. 

currently uses:

!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN"
        "http://www.w3.org/TR/1999/REC-html401-19991224/loose.dtd"

Did something change in the way it parses the DTD.

Ray A.

Comment 1

17 years ago
Im pretty sure this is a dupe of 155453

*** This bug has been marked as a duplicate of 155453 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 2

16 years ago
verifying
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.