Filename when downloading is shortened sometimes

RESOLVED INVALID

Status

Core Graveyard
File Handling
RESOLVED INVALID
16 years ago
a year ago

People

(Reporter: Timon Christl, Assigned: Bill Law)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.0) Gecko/20020529
BuildID:    2002052918

When downloading a file from Fileplanet (http://www.fileplanet.com) I often see
that the filename which Mozilla presents me in the File Selector has been
shortened by two characters. For example, when I try to download a file named
ktsdm3v2.zip I get sdm3v2.zip instead. This is very annoying and of course it's
wrong.

Reproducible: Sometimes
Steps to Reproduce:
1. Go to the example URL (or any other download at fileplanet.com)
2. Start downloading the file from one of the "Public Servers"
3. Another window pops up, with "Click here to start - xxx.zip". Click on that
4. Choose "Save this file to disk". The file selector appears


Actual Results:  Note that the filename Mozilla proposes in the file selector
has been shortened by two letters.

Expected Results:  Mozilla should not do this of course.

I don't know if this really is a Mozilla issue or simply a misconfigured server.
I saw this with some other servers, too, but I don't remember which ones. If
this is a Mozilla bug it has been around for at least a year, I think.

Note that you might have to register with GamespyID (it's for free) in order to
be able to access the download.
-> File Handling
Assignee: Matti → law
Component: Browser-General → File Handling
QA Contact: imajes-qa → sairuh

Comment 2

16 years ago
confirm win98se mozilla-1.0

I have reports from housemates that this ocurrs on the above platform and
browser, but as I don't use mozilla myself (Gecko, yes; mozilla, no) I can't
confirm for debian-3.0woody-pre

no specific info on particular hosts etc since I can't persuade anybody to keep
info sorry.
(Reporter)

Comment 3

16 years ago
I played around with Venkman to get nearer towards the source of this bug, and
found that in <mozilladir>/components/nsHelperAppDlg.js, in function 
promptForSaveToFile, the parameter aDefaultFile has already been shortened by
two letters, which means the filename was mangled somewhere before. The previous
frame on the call stack is the function saveToDisk, which is native code.
Unfortunately I don't know enough of the inner workings of Mozilla to help
beyond this point, but I hope someone will find the above information useful.
(Reporter)

Updated

16 years ago
QA Contact: sairuh → petersen

Comment 4

15 years ago
Does this bug exist in a current mozilla build ? please close
as WORKSFORME if not.
(Reporter)

Comment 5

15 years ago
Yes, I still experience that bug. Using Mozilla 1.2beta, Build ID 2002101612.
Don't know if current nightlies have this, though.

Comment 6

15 years ago
I am using: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2b) Gecko/20021016

I can confirm that I also occassionally see this bug. I also occasionally boot
into Linux, but I can't remember if I've seen this bug under Linux. Anyhow, as
the original poster commented, this is incorrect behavior, and a bit annoying.

Comment 7

15 years ago
Just to confirm that this bug still exists in 1.2.1 on RH Linux. 
E.g.
http://old.fileplanet.com/dl/dl.asp?/planetunreal/news/teamfreeze2003_beta012.zip
is saved as "eamfreeze2002_beta012.zip".

Comment 8

15 years ago
I'm using solaris nightly 2002120522. I can reproduce this, but it looks like a
bug with the fileplanet web site. I followed the link from comment #7 and
downloaded the file while snooping network traffic. Mozilla sent:

GET /%5E836316613/planetunreal/news/teamfreeze2003_beta012.zip HTTP/1.1
Host: xferla3.fileplanet.com
User-Agent: Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.3a) Gecko/20021205
Accept: text/xml,application/xml,application/xhtml+xml,
    text/html;q=0.9,text/plain;q=0.8,video/x-mng,image/png,
    image/jpeg,image/gif;q=0.2,*/*;q=0.1
Accept-Language: en-us,en;q=0.5
Accept-Encoding: gzip,deflate,compress;q=0.9
Accept-Charset: ISO-8859-1,utf-8;q=0.7,*;q=0.7
Keep-Alive: 300
Proxy-Connection: keep-alive

and fileplanet responded:

HTTP/1.1 200 OK
Date: Fri, 06 Dec 2002 22:47:09 GMT
Server: GameSpy-XFS/1.0
Connection: close
Content-Type: application/octet-stream
Accept-Ranges: bytes
Content-Disposition: file; filename=amfreeze2003_beta012.zip
Last-Modified: Tue, 03 Dec 2002 02:36:48 GMT
Content-Length: 34595

You can see the mangled name clearly in the Content-Disposition line.

I'm going to go ahead and resolve this.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.