Closed Bug 1515526 Opened Last year Closed Last year

python configure runs some depends functions twice

Categories

(Firefox Build System :: General, enhancement)

enhancement
Not set

Tracking

(firefox66 fixed)

RESOLVED FIXED
Tracking Status
firefox66 --- fixed

People

(Reporter: glandium, Assigned: glandium)

Details

Attachments

(1 file)

This is visible in the output:

 0:00.81 checking for a shell... /bin/sh
 0:00.86 checking for host system type... x86_64-pc-linux-gnu
 0:00.86 checking for target system type... x86_64-pc-linux-gnu
 0:00.91 checking for a shell... /bin/sh
 0:00.96 checking for host system type... x86_64-pc-linux-gnu
 0:00.96 checking for target system type... x86_64-pc-linux-gnu
 0:01.00 checking whether cross compiling... no
 0:01.07 checking for vcs source checkout... git
 0:01.07 checking whether cross compiling... no

The root cause is the need_help_dependency argument to some of the functions in configure/__init__.py. I think those should be removed and everything related to that should be done in lint.py.
Worth noting, this is only the visible part of the iceberg. Many depends functions don't print anything and are executed twice too.
It turns out all the changes related to --help linting in lint.py make
them unnecessary, and we still can detect missing --help arguments
without them, per test_lint.py. On the flip side, keeping those
need_help_dependency arguments makes some functions executed twice
because some memoized functions end up being called for both cases
need_help_dependency=True and need_help_dependency=False.
Assignee: nobody → mh+mozilla
Status: NEW → ASSIGNED
https://hg.mozilla.org/mozilla-central/rev/5d8df624d016
Status: ASSIGNED → RESOLVED
Closed: Last year
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.