Closed Bug 1515558 Opened 1 year ago Closed 4 months ago

Crash in nsPresContext::CacheAllLangs

Categories

(Core :: Layout, defect, P3, critical)

Unspecified
Android
defect

Tracking

()

RESOLVED WORKSFORME
Tracking Status
geckoview64 --- wontfix
geckoview65 --- wontfix
firefox64 --- wontfix
firefox65 --- affected
firefox66 --- ?

People

(Reporter: snorp, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: crash, regression, Whiteboard: [geckoview:p3])

Crash Data

This bug was filed from the Socorro interface and is
report bp-26a01bdf-3169-4280-a42f-e68d10181219.
=============================================================

Top 10 frames of crashing thread:

0 libxul.so nsPresContext::CacheAllLangs layout/base/nsPresContext.cpp:1882
1 libxul.so mozilla::ServoStyleSet::PreTraverse layout/style/ServoStyleSet.cpp:445
2 libxul.so mozilla::ServoStyleSet::StyleDocument layout/style/ServoStyleSet.cpp:971
3 libxul.so mozilla::RestyleManager::DoProcessPendingRestyles layout/base/RestyleManager.cpp:3024
4 libxul.so mozilla::PresShell::DoFlushPendingNotifications layout/base/PresShell.cpp:4326
5 libxul.so mozilla::dom::Selection::Stringify dom/base/Selection.cpp:420
6 libxul.so mozilla::AccessibleCaretManager::DispatchCaretStateChangedEvent layout/base/AccessibleCaretManager.cpp:1422
7 libxul.so mozilla::AccessibleCaretManager::UpdateCaretsForSelectionMode layout/base/AccessibleCaretManager.cpp:368
8 libxul.so mozilla::AccessibleCaretManager::OnReflow layout/base/AccessibleCaretManager.cpp:684
9 libxul.so mozilla::AccessibleCaretEventHub::Reflow layout/base/AccessibleCaretEventHub.cpp:670

=============================================================
Is this a dupe of bug 1445794?
Flags: needinfo?(aethanyc)
Yes, though note that I have a patch papering over this (not flushing when the document has already gone to the bfcache) in bug 1514511.
Flags: needinfo?(aethanyc)
Priority: -- → P3
See Also: → 1445794
(In reply to Emilio Cobos Álvarez (:emilio) from comment #2)
> Yes, though note that I have a patch papering over this (not flushing when
> the document has already gone to the bfcache) in bug 1514511.

Emilio, will additional work be needed in this bug after you paper over the crash in bug 1514511? Do you have an estimate of when you will be able to land bug 1514511?

This CacheAllLangs crash signature is Android top crash #2 (in Focus 8.0 testing of GeckoView 64).
Depends on: 1514511
Flags: needinfo?(emilio)
Whiteboard: [geckoview:p1]
(In reply to Chris Peterson (:cpeterson) from comment #3)
> This CacheAllLangs crash signature is Android top crash #2 (in Focus 8.0
> testing of GeckoView 64).

Correction: I meant this is top crash #7, not #2.
Whiteboard: [geckoview:p1] → [geckoview:p3]
(In reply to Chris Peterson (:cpeterson) from comment #3)
> Emilio, will additional work be needed in this bug after you paper over the
> crash in bug 1514511?

Nope, though we should probably fix the root cause which is bug 1445794.

> Do you have an estimate of when you will be able to land bug 1514511?

Whenever Boris gets to review the second patch there. Otherwise only the crash with that stuck would get fixed, which is not great.
Flags: needinfo?(emilio)

Whenever Boris gets to review the second patch there.

You mean in bug 1514511? I'm not flagged to review anything there....

Flags: needinfo?(emilio)

Oh wow, not sure what happened there... Sorry, should've noticed. :(

Flags: needinfo?(emilio)

I just check the crash report link in comment 0. There are still crash reports coming in as of today, but the version numbers are Firefox 65 or older. I believe the root cause has been addressed in either bug 1514511 or bug 1445794, where both are fixed in Firefox 66.

Status: NEW → RESOLVED
Closed: 4 months ago
Resolution: --- → WORKSFORME

Bugbug thinks this bug is a regression, but please revert this change in case of error.

Keywords: regression
You need to log in before you can comment on or make changes to this bug.