Closed Bug 1515585 Opened 2 years ago Closed 2 years ago

In Address bar: FF no longer adds "www." and ".com" to address when I hold CMD button and hit Return button

Categories

(Firefox :: Keyboard Navigation, defect)

64 Branch
Desktop
macOS
defect
Not set
normal

Tracking

()

RESOLVED WONTFIX

People

(Reporter: durstdesigns.us, Unassigned)

References

Details

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.13; rv:64.0) Gecko/20100101 Firefox/64.0

Steps to reproduce:

On a Mac (MacOS) type an address skipping the "www." and ".com", i.e. type: "firefox", then hold Command (CMD) button then press Enter (Return) button.


Actual results:

Firefox searched Google, rather than auto-adding the "www." and ".com" and subsequently requesting the homepage of the domain: www.firefox.com.

I have discovered that the Control button on the LEFT side of the keyboard now does what the CMD button used to do - which I would do with my ONE right hand - instead of requiring two hands for this simple shortcut.

Why is it that people (programmers) think they have to change things that have worked so well for more than a decade? I don't understand...  :-/


Expected results:

Type: "firefox", hold the CMD key and hit the Enter button, and FF automatically adds the "www." and ".com" to the address that has been typed in the Address Bar.

Who the heck changed this?!? I use this a million times a day. Please change it back to the way it was.
Thank you.
Why the heck should some software automatically add ".com" if there are gazillions of other top level domains nowadays compared to a decade ago? Why is it that people don't use Firefox' awesome bar to quickly choose proposed autocompletion entries instead of previously often wrong guesses which website the user wants to visit? Why am I personally reminded of http://www.xkcd.com/1172/ ? :)
Flags: needinfo?(durstdesigns.us)
I believe this will be closed as Invalid since it's an intentional change introduced in bug 237027. It has over 150 comments and concerns were already raised there; it's likely the pros and cons were thoroughly weighed before the change. NI :Gijs to make sure.

(In reply to Andre Klapper from comment #1)
> Why the heck should some software automatically add ".com"

It seems you missed the fact this involves a keyboard shortcut [1], not just typing a word and pressing Enter. "Complete .com address" is a longstanding feature of this and other browsers. As I recall, locales other than en-US complete other TLDs. It's also possible to customize the value of browser.fixup.alternate.suffix in about:config.


[1] https://support.mozilla.org/kb/keyboard-shortcuts-perform-firefox-tasks-quickly
Blocks: 237027
Has STR: --- → yes
Component: Untriaged → Keyboard Navigation
Flags: needinfo?(durstdesigns.us) → needinfo?(gijskruitbosch+bugs)
OS: Unspecified → Mac OS X
Hardware: Unspecified → Desktop
Yes, this is by design. `ctrl-enter` still does what you expect. This was mentioned in the release notes here: https://www.mozilla.org/en-US/firefox/64.0/releasenotes/ as "The macOS keyboard shortcut to add "www" and ".com" to a URL is now ctrl-enter instead of ⌘[cmd]-enter"

(In reply to durstdesigns.us from comment #0)
> Why is it that people (programmers) think they have to change things that
> have worked so well for more than a decade? I don't understand...  :-/

Because it broke people's expectations in other ways, was inconsistent with other parts of the browser and inconsistent with other browsers.

>
> Who the heck changed this?!?

Me.

> I use this a million times a day. Please change it back to the way it was.

Unfortunately, we won't be doing that. I would suggest creating bookmarks for sites you use regularly and/or using history and "normal" autocomplete to achieve the results that you want.

bug 1325692 covers allowing webextensions to override builtin shortcuts. I believe we're working on some of the work that's needed in that area, so that may become a possibility in future Firefox versions.
Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago
Flags: needinfo?(gijskruitbosch+bugs)
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.