Cannot open date-picker popup in custom reminder dialog

RESOLVED FIXED in 6.7

Status

RESOLVED FIXED
2 months ago
29 days ago

People

(Reporter: ssitter, Assigned: MakeMyDay)

Tracking

({regression})

Lightning 6.6
regression

Details

Attachments

(1 attachment)

(Reporter)

Description

2 months ago
Thunderbird 66.0a1 (BuildID 20181221092739) with Lightning 6.8a1

In the custom reminder dialog the date picker popup doesn't work. Console shows the following errors:

> TypeError: this.kMinimonth.update is not a function[Learn More] datetimepickers.xml:340:13
> 
> onPopup chrome://calendar/content/datetimepickers/datetimepickers.xml:340 
> onpopupshowing chrome://calendar/content/calendar-event-dialog-reminder.xul:1 
> editReminder chrome://calendar/content/calendar-dialog-utils.js:153 
> commonUpdateReminder chrome://calendar/content/calendar-dialog-utils.js:421 
> updateReminder chrome://lightning/content/lightning-item-iframe.js:1502 
> oncommand chrome://lightning/content/lightning-item-iframe.xul:1 

> TypeError: this.firstChild.focusCalendar is not a function[Learn More] calendar-event-dialog-reminder.xul:1:1
> 
> onpopupshown chrome://calendar/content/calendar-event-dialog-reminder.xul:1 
> editReminder chrome://calendar/content/calendar-dialog-utils.js:153 
> commonUpdateReminder chrome://calendar/content/calendar-dialog-utils.js:421 
> updateReminder chrome://lightning/content/lightning-item-iframe.js:1502 
> oncommand chrome://lightning/content/lightning-item-iframe.xul:1 

> TypeError: this.firstChild.hidePopupList is not a function[Learn More] calendar-event-dialog-reminder.xul:1:1
> 
> onpopuphiding chrome://calendar/content/calendar-event-dialog-reminder.xul:1 
> editReminder chrome://calendar/content/calendar-dialog-utils.js:153 
> commonUpdateReminder chrome://calendar/content/calendar-dialog-utils.js:421 
> updateReminder chrome://lightning/content/lightning-item-iframe.js:1502 
> oncommand chrome://lightning/content/lightning-item-iframe.xul:1
(Reporter)

Comment 1

2 months ago
Same problem using Thunderbird 64.0b4 (BuildID 20181129151909) with Lightning 6.6b4.
Version: Lightning 6.8 → Lightning 6.6
(Assignee)

Comment 2

2 months ago
I don't see this (c-c pulled at 28-12-2018) in my local build on Windows. For which platform do you observe this?
Flags: needinfo?(ssitter)
(Assignee)

Comment 3

2 months ago
Sorry, I looked at the wrong place, I'm seeing it now. Do you have older betas at hand to narrow the regression range? ESR is working fine.

Geoff, is this related to bug 1507304 or its predecessor?
Flags: needinfo?(geoff)
Keywords: regression
That dialog seems to be missing calendar-widget-bindings.css.
Flags: needinfo?(geoff)
Bug 1474123 is what caused that, I think.
(Assignee)

Comment 6

2 months ago
Yes, this was it.
Assignee: nobody → makemyday
Blocks: 1474123
Status: NEW → ASSIGNED
Flags: needinfo?(ssitter)
(Assignee)

Comment 7

2 months ago
Created attachment 9033776 [details] [diff] [review]
DatepickerInReminderDialogDoesntShowUp-V1.diff
Attachment #9033776 - Flags: review?(philipp)
Attachment #9033776 - Flags: approval-calendar-beta?(philipp)
(Reporter)

Comment 8

2 months ago
Would the same/similar fix work for bug 1499475?
(Assignee)

Comment 9

2 months ago
Yes, see that bug.
Attachment #9033776 - Flags: review?(philipp)
Attachment #9033776 - Flags: review+
Attachment #9033776 - Flags: approval-calendar-beta?(philipp)
Attachment #9033776 - Flags: approval-calendar-beta+
(Assignee)

Updated

a month ago
Keywords: checkin-needed

Comment 10

a month ago

Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/bc4167748b7d
Datepicker in reminder dialog doesn't show up; r=philipp

Status: ASSIGNED → RESOLVED
Last Resolved: a month ago
Keywords: checkin-needed
Resolution: --- → FIXED

Updated

a month ago
Target Milestone: --- → 6.8
You need to log in before you can comment on or make changes to this bug.