Closed Bug 1516028 Opened Last year Closed Last year

Google search engine has disappeared from search options which makes Bing the default

Categories

(Firefox for Android :: General, defect, P1, major)

Firefox 66
defect

Tracking

()

RESOLVED FIXED
Firefox 67
Tracking Status
firefox65 --- unaffected
firefox66 - wontfix
firefox67 + fixed

People

(Reporter: blueboxer1, Assigned: mkaply)

References

Details

(Keywords: regression)

Attachments

(2 files, 1 obsolete file)

User Agent: Mozilla/5.0 (Android 8.1.0; Mobile; rv:66.0) Gecko/66.0 Firefox/66.0

Steps to reproduce:

Auto updated to 66.0a1. Searched for something (assumed using Google)


Actual results:

Bing results showed up. Bing had been made default and Google completely disappeared from search options


Expected results:

Search using Google
Android 8.1
I can confirm this on my Pixel 3, using the latest nightly build. Regression range: https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=d0e13414d6512c9fe84911a0dd730e4fb4a28c27&tochange=e16b548dc14c58efd713bfac10a5944fd6bdfc5e.

Bug 1510296 looks like a strong suspect. ni on :mkaply
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(mozilla)
Keywords: regression
Screenshot from the latest nightly Fennec build.
A local backout of bug 1510296 brings back Google for me in my android build.
Depends on: 1510296
Blocks: 1510296
No longer depends on: 1510296
This is fixed with the backout. Sorry about the trouble. When I reland, I'll have mobile and desktop patches together.
Flags: needinfo?(mozilla)
Thanks for the quick reply.
Duplicate of this bug: 1516057
I can verify the backout fixes it - the only thing is I had to set my default search engine back to Google (from Bing).
Severity: normal → major
Is there any follow up we can do here? Would anyone who hit this issue have had their default changed?
Flags: needinfo?(sdaswani)
Flags: needinfo?(mozilla)
> Is there any follow up we can do here? Would anyone who hit this issue have had their default changed?

This should be very limited and most people should get it changed back automatically (if they didn't go to settings and change it there).

So I don't think we need to do anything here.
Flags: needinfo?(sdaswani)
Flags: needinfo?(mozilla)
Marcia and Julien had to change it back manually. That's why I mention that I don't think it's changing back automatically. We can keep on the lookout for further reports or we can do some testing. Is there telemetry on Nightly that tells us aggregate info about what the default search engine is set to?
Flags: needinfo?(mozilla)
I tested this again on my Pixel 2. Here is my process:

1. Uninstalled the existing Firefox Nightly from my Pixel running Android Pie
2. Restarted my device
3. Sideloaded the apk from 12-21
4. Confirmed that Bing was the default by checking settings and performing a search
5. Updated to the latest build (12-26)
6. Confirmed that Bing is still set as my default and that I have to manually switch the search engine back to Google.

I did not clear app cache is storage, but I am guessing even if that was needed an average user isn't likely to do that.
I'm investigating why it didn't change back. We haven't received any other reports that I have found.

I think because it was nightly and right before Christmas, not many folks got the update.
Flags: needinfo?(mozilla)

I'm going to take this so we can make sure this doesn't happen in the future. I'll open another bug for the test.

Assignee: nobody → mozilla
Status: NEW → ASSIGNED

(In reply to Mike Kaply [:mkaply] from comment #14)

I'm going to take this so we can make sure this doesn't happen in the future. I'll open another bug for the test.

Hello Mike - Do you have a bug number for the test? Thanks.

Mike is this still a patch you intend to land?

Flags: needinfo?(mozilla)

Mike is this still a patch you intend to land?

No, I'm concerned this would use a user's choice. Still investigating.

Flags: needinfo?(mozilla)
Attachment #9034843 - Attachment is obsolete: true

Mike, when this lands please let me know if you think it will be good for uplift to beta.

Flags: needinfo?(mozilla)

Dale, are you able to do the review here? (I'm unsure if you and Mike have been speaking off-bugzilla so sorry if this is an unnecessary ping)

Flags: needinfo?(dharvey)

Ugh sorry nope, just another missed phabricator email, apologies, will get to it today shortly

Flags: needinfo?(dharvey)
Pushed by mozilla@kaply.com:
https://hg.mozilla.org/integration/autoland/rev/6518ca61dbd0
Don't allow a null originalDefaultEngine. r=daleharvey
Status: ASSIGNED → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → Firefox 67

I think this can ride the train. This was more about making sure this doesn't happen in the future.

You need to log in before you can comment on or make changes to this bug.