Closed Bug 1516111 Opened Last year Closed Last year

Crash in PLDHashTable::Search | mozilla::dom::LSDatabase::~LSDatabase

Categories

(Core :: DOM: Core & HTML, defect, critical)

66 Branch
x86_64
macOS
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 1516231
Tracking Status
firefox66 --- affected

People

(Reporter: mb8672, Unassigned)

Details

Crash Data

This bug was filed from the Socorro interface and is
report bp-97d859d1-177a-4678-acc3-dfbe80181222.
=============================================================

Top 10 frames of crashing thread:

0 XUL PLDHashTable::Search const xpcom/ds/PLDHashTable.cpp:497
1 XUL mozilla::dom::LSDatabase::~LSDatabase xpcom/ds/nsTHashtable.h:135
2 XUL mozilla::dom::LSSnapshot::~LSSnapshot dom/localstorage/LSDatabase.cpp:36
3 XUL mozilla::dom::LSSnapshot::Finish dom/localstorage/LSSnapshot.cpp:41
4 XUL nsTimerImpl::Fire xpcom/threads/nsTimerImpl.cpp:559
5 XUL nsTimerEvent::Run xpcom/threads/TimerThread.cpp:259
6 XUL nsThread::ProcessNextEvent xpcom/threads/nsThread.cpp:1157
7 XUL NS_ProcessNextEvent xpcom/threads/nsThreadUtils.cpp:468
8 XUL mozilla::ipc::MessagePump::Run ipc/glue/MessagePump.cpp:110
9 XUL nsBaseAppShell::Run ipc/chromium/src/base/message_loop.cc:314

=============================================================

3 crashes while sitting on an idle Reddit user page in classic mode, not reddit redesign.
How feasible is it that this might lock up the browser? I've been seeing that in the last two days, just ended up with this bug filed, and it looks like related crashes started 12/22/2018 @ 12:48am (UTC). See 1516136 and Bug 1516104.
Very low chance of crashing Firefox.  Only tab crashes have happened so far. For me, its only been on Reddit.
Looks as if there were some crashes in nightly in builds from 12-22 and 12-23, but none since then.
Duping this to Bug 1516231, as it appears to be the same underlying issue.
Status: UNCONFIRMED → RESOLVED
Closed: Last year
Resolution: --- → DUPLICATE
Duplicate of bug: 1516231
It's not crashing now because next gen storage has been toggled off again, see bug 1516136.
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.