Closed Bug 1516231 Opened 1 year ago Closed 1 year ago

Crash in PLDHashTable::Search | nsBaseHashtable<T>::Remove | mozilla::dom::LSDatabase::AllowToClose

Categories

(Core :: Storage: localStorage & sessionStorage, defect, P3, critical)

defect

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: gsvelto, Unassigned)

References

Details

(Keywords: crash)

Crash Data

This bug was filed from the Socorro interface and is
report bp-00f632d6-d8b8-47bd-a07a-8d1710181224.
=============================================================

Top 10 frames of crashing thread:

0 xul.dll PLDHashTable::Search xpcom/ds/PLDHashTable.cpp:497
1 xul.dll bool nsBaseHashtable<nsCStringHashKey, bundleCacheEntry_t*, bundleCacheEntry_t*>::Remove xpcom/ds/nsInterfaceHashtable.h:172
2 xul.dll void mozilla::dom::LSDatabase::AllowToClose dom/localstorage/LSDatabase.cpp:314
3 xul.dll void mozilla::dom::LSDatabase::~LSDatabase dom/localstorage/LSDatabase.cpp:41
4 xul.dll unsigned long mozilla::dom::LSDatabase::Release dom/localstorage/LSDatabase.h:31
5 xul.dll void mozilla::dom::LSSnapshot::~LSSnapshot dom/localstorage/LSSnapshot.cpp:52
6 xul.dll mozilla::dom::LSSnapshot::Release dom/localstorage/LSSnapshot.cpp:707
7 xul.dll nsTimerImpl::Fire xpcom/threads/nsTimerImpl.cpp:559
8 xul.dll nsTimerEvent::Run xpcom/threads/TimerThread.cpp:259
9 xul.dll nsThread::ProcessNextEvent xpcom/threads/nsThread.cpp:1157

=============================================================
Crash Signature: [@ PLDHashTable::Search | nsBaseHashtable<T>::Remove | mozilla::dom::LSDatabase::AllowToClose] → [@ PLDHashTable::Search | nsBaseHashtable<T>::Remove | mozilla::dom::LSDatabase::AllowToClose] [@ <name omitted> | nsBaseHashtable<T>::Remove | mozilla::dom::LSDatabase::AllowToClose ]
No crashes seen after 20181223170426 - they started in 20181222220504. Maybe something was backed out?

Regression range based on build ids would have been https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=e16b548dc14c58efd713bfac10a5944fd6bdfc5e&tochange=8330fe920aeaae610a19f76956e1c47d67dc7be5.
Duplicate of this bug: 1516111
Adding the Mac specific signature from the duped bug.
Crash Signature: [@ PLDHashTable::Search | nsBaseHashtable<T>::Remove | mozilla::dom::LSDatabase::AllowToClose] [@ <name omitted> | nsBaseHashtable<T>::Remove | mozilla::dom::LSDatabase::AllowToClose ] → [@ PLDHashTable::Search | nsBaseHashtable<T>::Remove | mozilla::dom::LSDatabase::AllowToClose] [@ <name omitted> | nsBaseHashtable<T>::Remove | mozilla::dom::LSDatabase::AllowToClose ] [@ PLDHashTable::Search | mozilla::dom::LSDatabase::~LSDatabase]
OS: Windows → All
(In reply to Marcia Knous [:marcia - needinfo? me] from comment #1)
> No crashes seen after 20181223170426 - they started in 20181222220504. Maybe
> something was backed out?

Yes, this was caused by next-gen local storage which had been tentatively enabled. We pref'd it off again on the 24th. Blocking the appropriate bug.
Blocks: 1510410
Priority: -- → P3
Blocks: 1517090
No longer blocks: 1510410
Flags: needinfo?(bugmail)

Ok, we re-enabled LSNG and there are no crash reports like this anymore.
I think we can close this one.

Status: NEW → RESOLVED
Closed: 1 year ago
Flags: needinfo?(bugmail)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.