Closed Bug 1516253 Opened 11 months ago Closed 7 months ago

Local Windows builds busted: error: linker `link.exe` not found

Categories

(Thunderbird :: Build Config, defect, blocker)

Unspecified
Windows
defect
Not set
blocker

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: infofrommozilla, Unassigned)

References

(Blocks 1 open bug)

Details

+++ This bug was initially created as a clone of Bug #1516090 +++

With the patch of bug 1516090 - (attachment 9033107 [details]) I get:

| 5:17.64 comm/mailnews/base/search/src
| 5:24.84    Compiling winapi v0.3.6 (https://github.com/froydnj/winapi-rs?branch=aarch64#4e52ee21)
| 5:30.53    Compiling unicode-xid v0.1.0
| 5:31.33    Compiling winapi v0.3.6 (https://github.com/froydnj/winapi-rs?branch=aarch64#4e52ee21)
| 5:32.28 error: linker `link.exe` not found
| 5:32.28   |
| 5:32.28   = note: Das System kann die angegebene Datei nicht finden. (os error 2)
| 5:32.28 note: the msvc targets depend on the msvc linker but `link.exe` was not found
| 5:32.28 note: please ensure that VS 2013, VS 2015 or VS 2017 was installed with the Visual C++ option
| 5:32.28 error: aborting due to previous error
| 5:32.64 error: Could not compile `winapi`.
| 5:32.64 To learn more, run the command again with --verbose.
| 5:32.69 mozmake.EXE[4]: *** [s:/Projects/mozi/mozilla/config/rules.mk:1102: force-cargo-host-program-build] Error 101
| 5:32.69 mozmake.EXE[3]: *** [s:/Projects/mozi/mozilla/config/recurse.mk:74: js/src/frontend/binsource/host] Error 2
| 5:32.69 mozmake.EXE[3]: *** Waiting for unfinished jobs....
| 5:34.59    Compiling serde v1.0.80
| 5:38.08 error: linker `link.exe` not found
| 5:38.08   |
| 5:38.08   = note: Das System kann die angegebene Datei nicht finden. (os error 2)

extending the PATH with the directory of the MSVS build binaries fixes the problem
Depends on: 1516090
No longer depends on: 1516090
You haven't installed MSVC with the MSVC installer, have you?
(In reply to Mike Hommey [:glandium] from comment #1)
> You haven't installed MSVC with the MSVC installer, have you?

Yes, VS2017 15.9.4 community edition

Presumably, this will be fixed by bug 1524396.

I'll assume comment 3 is true. Please reopen if that's not the case.

Status: UNCONFIRMED → RESOLVED
Closed: 7 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.