Emoji with font-size > 8em not displayed

VERIFIED FIXED in Firefox 65

Status

()

P3
normal
VERIFIED FIXED
3 months ago
3 months ago

People

(Reporter: bugzilla, Assigned: lsalzman)

Tracking

({regression})

65 Branch
mozilla66
Unspecified
macOS
regression
Points:
---

Firefox Tracking Flags

(firefox-esr60 unaffected, firefox64 unaffected, firefox65+ verified, firefox66+ verified)

Details

(Whiteboard: [gfx-noted])

Attachments

(1 attachment)

(Reporter)

Description

3 months ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.14; rv:65.0) Gecko/20100101 Firefox/65.0

Steps to reproduce:

Create a page with an emoji with font-size bigger than 8em. Reduced test case here: https://codepen.io/BernhardWebstudio/pen/yGXgBz

Open that page in Firefox. Tested on Mac with latest (65.0b6) & nightly (66) build.


Actual results:

The emojies with font-size larger than 8em do not get rendered. Emojis with font-size 8em do get rendered. 


Expected results:

I expect all emojis to be rendered.

Updated

3 months ago
OS: Unspecified → Mac OS X
Component: Untriaged → Graphics: Text
Product: Firefox → Core
This was regressed by the Skia update in bug 1502152.
Blocks: 1502152
Flags: needinfo?(lsalzman)
Keywords: regression
It appears the exact size limit (above which the emoji fail to render) is 128px on a retina display, and 256px on non-retina, indicating that the cutoff is a font size of 256 device pixels.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Updated

3 months ago
Flags: needinfo?(lsalzman)
Priority: -- → P3
Whiteboard: [gfx-noted]
(Assignee)

Comment 3

3 months ago
This just restores the fix we made in bug 1267180. It got nuked accidentally due to code churn from the Skia m71 update.
Assignee: nobody → lsalzman
Status: NEW → ASSIGNED
Attachment #9033366 - Flags: review?(rhunt)

Updated

3 months ago
Attachment #9033366 - Flags: review?(rhunt) → review+

Comment 4

3 months ago
Pushed by lsalzman@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/ee0e1df960c4
don't draw emoji as paths when they are too big. r=rhunt

Comment 5

3 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/ee0e1df960c4
Status: ASSIGNED → RESOLVED
Last Resolved: 3 months ago
status-firefox66: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla66
Probably worth requesting beta uplift for this, so we don't ship the regression in 65.
Flags: needinfo?(lsalzman)
(Assignee)

Comment 7

3 months ago
Comment on attachment 9033366 [details] [diff] [review]
don't draw emoji as paths when they are too big

[Beta/Release Uplift Approval Request]

Feature/Bug causing the regression: Bug 1502152

User impact if declined: Large emoji fail to render.

Is this code covered by automated tests?: Yes

Has the fix been verified in Nightly?: Yes

Needs manual test from QE?: No

If yes, steps to reproduce: 

List of other uplifts needed: None

Risk to taking this patch: Low

Why is the change risky/not risky? (and alternatives if risky): This just restores previous code that was accidentally regressed/removed by bug 1502152.

String changes made/needed:
Flags: needinfo?(lsalzman)
Attachment #9033366 - Flags: approval-mozilla-beta?
status-firefox64: --- → unaffected
status-firefox65: --- → affected
status-firefox-esr60: --- → unaffected
tracking-firefox65: --- → +
tracking-firefox66: --- → +
Flags: qe-verify+
Comment on attachment 9033366 [details] [diff] [review]
don't draw emoji as paths when they are too big

[Triage Comment]
Fixes an emoji rendering regression caused by the most recent Skia update shipping in Fx65. Approved for 65.0b8.
Attachment #9033366 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

Comment 9

3 months ago
bugherderuplift
https://hg.mozilla.org/releases/mozilla-beta/rev/dac7e82e8fcf
status-firefox65: affected → fixed
on OSX 10.14.2:
Using test case from comment 0, reproduced the issue  with Beta 65.0b6 and verified the fix on: 65.0b8/2019-01-03  and 66.0a1/2019-01-03
Status: RESOLVED → VERIFIED
status-firefox65: fixed → verified
status-firefox66: fixed → verified
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.