firefox build fails because of a compile error with `--disable-tests`

RESOLVED FIXED

Status

()

defect
RESOLVED FIXED
6 months ago
6 months ago

People

(Reporter: jsearle3, Assigned: ccorcoran)

Tracking

({regression})

unspecified
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr60 unaffected, firefox64 unaffected, firefox65 unaffected, firefox66 fixed)

Details

Attachments

(2 attachments)

Reporter

Description

6 months ago
Posted file mozconfig
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/64.0.3282.140 Safari/537.36 Edge/18.17763

Steps to reproduce:

./mach build
after having merged
$ hg heads
changeset:   451967:47d3977ee67e
tag:         tip
parent:      451955:f90034ef430e
parent:      451966:062104031126
user:        arthur.iakab <aiakab@mozilla.com>
date:        Tue Dec 25 11:51:08 2018 +0200
summary:     Merge inbound to mozilla-central a=merge

changeset:   451942:1f1eb65370ac
parent:      451919:a425f3e250f6
parent:      451941:d2bc993e14ea
user:        Joe Searle <jsearlr3@verizon.net>
date:        Mon Dec 24 17:00:46 2018 -0800
summary:     Merge Updates

Build successfully for the first time in 5 or 6 days after having taken in a backout of a previous problem yesterday. Back to being broken on windows today.


Actual results:


 9:01.02 toolkit/xre
 9:09.05 In file included from c:/mozilla-source/mozilla-central/obj-x86_64-pc-mingw32/toolkit/xre/Unified_cpp_toolkit_xre0.cpp:56:
 9:09.06 c:/mozilla-source/mozilla-central/toolkit/xre/ModuleEvaluator_windows.cpp(221,20):  error: redefinition of 'scoreThreshold' with a different type: 'const int' vs 'int'
 9:09.06   static const int scoreThreshold = 100;
 9:09.06                    ^
 9:09.06 c:/mozilla-source/mozilla-central/toolkit/xre/ModuleEvaluator_windows.cpp(207,7):  note: previous definition is here
 9:09.06   int scoreThreshold = 100;
 9:09.06       ^


Expected results:

Should have compiled without errors.
It was broken by this changeset:
https://searchfox.org/mozilla-central/diff/b2b3ea7d038e56c72278b89956c1ee91fd5057b6/toolkit/xre/ModuleEvaluator_windows.cpp#210
`int scoreThreshold = 100;` should be inside the `#if ENABLE_TESTS` block.
Blocks: 1513176
Flags: needinfo?(ccorcoran)
Summary: firefox build fails because of a compile error. → firefox build fails because of a compile error with `--disable-tests`
Assignee

Comment 2

6 months ago
When compiling without ENABLE_TESTS, the following error occurs:

/toolkit/xre/ModuleEvaluator_windows.cpp(221,20):  error: redefinition of
    'scoreThreshold' with a different type: 'const int' vs 'int'

This removes the 2 lines of code that caused the error.
Assignee

Updated

6 months ago
Flags: needinfo?(ccorcoran)
Keywords: checkin-needed

Comment 3

6 months ago
Pushed by rgurzau@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/454e10960236
Fix duplicate definition of scoreThreshold causing compile error with `--disable-tests` r=gcp
Keywords: checkin-needed

Comment 4

6 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/454e10960236
Status: UNCONFIRMED → RESOLVED
Closed: 6 months ago
Resolution: --- → FIXED
Assignee: nobody → ccorcoran
Product: Firefox Build System → Toolkit
Version: 6 Branch → unspecified
You need to log in before you can comment on or make changes to this bug.