Closed Bug 1516414 Opened 2 years ago Closed 2 years ago

[remote-dbg-next] Frequent failures of sidebar_usb_unknown_runtime.js on "getProcess"

Categories

(DevTools :: about:debugging, defect, P3)

defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1518581

People

(Reporter: jdescottes, Unassigned)

Details

When running the whole suite locally, I get intermittent failures with the following log:

devtools/client/aboutdebugging-new/test/browser/browser_aboutdebugging_sidebar_usb_unknown_runtime.js
  FAIL A promise chain failed to handle a rejection: Connection closed, pending error from root, type getProcess failed - stack: _queueResponse/responsePromise<@resource://devtools/server/main.js:1192:15
promise callback*_queueResponse@resource://devtools/server/main.js:1190:8
onPacket@resource://devtools/server/main.js:1340:7
send/<@resource://devtools/shared/transport/local-transport.js:64:11
exports.makeInfallible/<@resource://devtools/shared/ThreadSafeDevToolsUtils.js:109:14
DevToolsUtils.executeSoon*exports.executeSoon@resource://devtools/shared/DevToolsUtils.js:57:21
send@resource://devtools/shared/transport/local-transport.js:58:7
send@resource://devtools/shared/protocol.js:1391:9
request@resource://devtools/shared/protocol.js:1409:5
Priority: -- → P3
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1518581
No longer blocks: remote-debugging-ng-m2
You need to log in before you can comment on or make changes to this bug.