Enable VR process in Nightly, on Windows

RESOLVED FIXED in Firefox 66

Status

()

defect
RESOLVED FIXED
6 months ago
4 months ago

People

(Reporter: daoshengmu, Assigned: daoshengmu)

Tracking

unspecified
mozilla66
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox66 fixed)

Details

Attachments

(7 attachments, 1 obsolete attachment)

Assignee

Description

6 months ago
No description provided.
Assignee

Updated

6 months ago
Assignee: nobody → dmu
Blocks: 1362578

Comment 2

5 months ago
Pushed by dmu@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/87219897a280
Enable VR process in Nightly Windows. r=kip
Assignee

Updated

5 months ago
Depends on: 1519686
Assignee

Comment 12

5 months ago

I find a regression at Bug 1519686 about using nsString::BeginWriting() to get the lib path at OculusSession::LoadOvrLib(). We can work around it by using raw char16_t* instead of nsString.

Attachment #9035785 - Attachment is obsolete: true

Comment 14

5 months ago
Pushed by dmu@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/115387297036
Enable VR process in Nightly Windows. r=kip
https://hg.mozilla.org/integration/autoland/rev/8617fed7a3e0
Part 2: Fix nsTSubstring assertion when looking for Oculus VR lib. r=kip
https://hg.mozilla.org/integration/autoland/rev/625005dcd0b3
Part 3: Fix VRGPUParent memory leak in the destructor. r=kip
https://hg.mozilla.org/integration/autoland/rev/bff1af3da433
Part 4: Fix Win 7 try fails when VR process enable but no GPU process. r=kip
https://hg.mozilla.org/integration/autoland/rev/518dbd08c0d7
Part 5: Allow VR using the existing shmem. r=kip
https://hg.mozilla.org/integration/autoland/rev/ffe71a987b82
Part 6: Remove BackgroundHangMonitor in VRProcessChild because we will init it by XPCOM. r=kip
https://hg.mozilla.org/integration/autoland/rev/829462dca352
Part 7: Resolve MessageLoop destroy before VR IPC channels close issue. r=kip

Performance improvement

== Change summary for alert #18737 (as of Mon, 14 Jan 2019 20:00:57 GMT) ==

Improvements:

2% Base Content Heap Unclassified windows10-64-qr opt stylo 1,605,017.33 -> 1,567,746.67

For up to date results, see: https://treeherder.mozilla.org/perf.html#/alerts?id=18737

Assignee

Updated

5 months ago
Duplicate of this bug: 1519686

\o/ woot!

Assignee

Updated

4 months ago
See Also: → 1524929
You need to log in before you can comment on or make changes to this bug.