Closed Bug 1516644 Opened Last year Closed 10 months ago

MBasicBlock::MBasicBlock: guard lineno_ and columnIndex_ initialisations correctly

Categories

(Core :: JavaScript Engine: JIT, enhancement, P3)

enhancement

Tracking

()

RESOLVED FIXED
mozilla67
Tracking Status
firefox67 --- fixed

People

(Reporter: jseward, Assigned: jseward)

Details

Attachments

(1 file)

class MBasicBlock has this

  #if defined(JS_ION_PERF) || defined(DEBUG)
    unsigned lineno_;
    unsigned columnIndex_;

but the initialisation in MBasicBlock::MBasicBlock is guarded thusly

  #if defined(JS_ION_PERF)
        ,
        lineno_(0u),
        columnIndex_(0u)

which causes valgrind to complain a lot and generally cause confusion,
in debug builds when running with IONFLAGS=codegen,regalloc
Assignee: nobody → jseward
Attachment #9033538 - Flags: review?(nicolas.b.pierron)
Attachment #9033538 - Flags: review?(nicolas.b.pierron) → review+
Priority: -- → P3
Pushed by jseward@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/4d9aebc3fabb
MBasicBlock::MBasicBlock: guard lineno_ and columnIndex_ initialisations correctly.  r=nbp.

Push with failures: https://treeherder.mozilla.org/#/jobs?repo=mozilla-inbound&resultStatus=busted&revision=4d9aebc3fabb38f3f19609143e2614bef8828433&selectedJob=230377222

Failure log: https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=230377222&repo=mozilla-inbound&lineNumber=1612

Backout link: https://hg.mozilla.org/integration/mozilla-inbound/rev/da2011424e20b45490cf10e1b821b6baf5d70e23

20:34:46 INFO - DEBUG 2019-02-25T20:34:46Z: sccache::config: Couldn't open config file: The system cannot find the path specified. (os error 3)
20:34:46 INFO - Starting sccache server...
20:34:51 INFO - error: Timed out waiting for server startup
20:34:51 INFO - client.mk:80: recipe for target 'build' failed
20:34:51 INFO - mozmake.EXE: *** [build] Error 2
20:34:51 INFO - 0 compiler warnings present.
20:34:51 ERROR - Return code: 2
20:34:51 WARNING - setting return code to 2
20:34:51 FATAL - 'mach build -v' did not run successfully. Please check log for errors.
20:34:51 FATAL - Running post_fatal callback...
20:34:51 FATAL - Exiting -1
20:34:51 INFO - [mozharness: 2019-02-25 20:34:51.245000Z] Finished build step (failed)
20:34:51 INFO - Running post-run listener: _parse_build_tests_ccov
20:34:51 INFO - Running post-run listener: _shutdown_sccache
20:34:51 INFO - Running command: ['z:\build\build\src\sccache2\sccache.exe', '--stop-server'] in z:\build\build\src
20:34:51 INFO - Copy/paste: z:\build\build\src\sccache2\sccache.exe --stop-server
20:34:51 INFO - Stopping sccache server...
20:34:52 INFO - error: couldn't connect to server
20:34:52 INFO - caused by: No connection could be made because the target machine actively refused it. (os error 10061)
20:34:52 ERROR - Return code: 2
20:34:52 INFO - Running post-run listener: _summarize
20:34:52 ERROR - # TBPL FAILURE #
20:34:52 INFO - [mozharness: 2019-02-25 20:34:52.256000Z] FxDesktopBuild summary:
20:34:52 ERROR - # TBPL FAILURE #
[taskcluster 2019-02-25T20:34:52.272Z] Exit Code: 4294967295

Flags: needinfo?(jseward)
Pushed by csabou@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/9fe57a98497d
MBasicBlock::MBasicBlock: guard lineno_ and columnIndex_ initialisations correctly.  r=nbp.
Flags: needinfo?(jseward)
Status: NEW → RESOLVED
Closed: 10 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla67
You need to log in before you can comment on or make changes to this bug.