Closed Bug 1516713 Opened 10 months ago Closed 10 months ago

Move buildId-related stuff out of jsapi.h into a new js/public/BuildId.h header

Categories

(Core :: JavaScript Engine, enhancement)

enhancement
Not set

Tracking

()

RESOLVED FIXED
mozilla66
Tracking Status
firefox66 --- fixed

People

(Reporter: Waldo, Assigned: Waldo)

Details

Attachments

(1 file)

Noticed some of this in passing working on the asm.js stuff, realized it was an easy thing to move to its own header.
Attached patch PatchSplinter Review
Somewhat oddly, JS::GetOptimizedEncodingBuildId is never called anywhere.  Not sure why that is, nor why the symbol is public given that, exactly.  Maybe you BinAST peoples are planning to use it in WIP patches or something?  *shrug*
Attachment #9033591 - Flags: review?(arai.unmht)
Comment on attachment 9033591 [details] [diff] [review]
Patch

Review of attachment 9033591 [details] [diff] [review]:
-----------------------------------------------------------------

BinAST related code won't use build id.
Attachment #9033591 - Flags: review?(arai.unmht) → review+
Pushed by jwalden@mit.edu:
https://hg.mozilla.org/integration/mozilla-inbound/rev/2d17e4ef5e71
Move buildId-related stuff out of jsapi.h into a new js/public/BuildId.h header.  r=arai
https://hg.mozilla.org/mozilla-central/rev/2d17e4ef5e71
Status: ASSIGNED → RESOLVED
Closed: 10 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla66
Pushed by jwalden@mit.edu:
https://hg.mozilla.org/integration/mozilla-inbound/rev/13029582fcc6
Move buildId-related stuff out of jsapi.h into a new js/public/BuildId.h header.  r=arai
You need to log in before you can comment on or make changes to this bug.