Closed Bug 1516741 Opened 2 years ago Closed 2 years ago

Provide Thunderbird MSI package

Categories

(Thunderbird :: Installer, enhancement)

All
Windows
enhancement
Not set
normal

Tracking

(thunderbird68+)

RESOLVED FIXED
Thunderbird 68.0
Tracking Status
thunderbird68 + ---

People

(Reporter: rjl, Assigned: rjl)

References

(Blocks 1 open bug)

Details

Attachments

(1 file, 2 obsolete files)

+++ This bug was initially created as a clone of Bug #274624 +++

Follow-up bug for bug 274624 to track the fixes that need to go in before completion.

- Work in beetmover and bouncerscript (maintained by releng bug 1516475 and bug 1516542)
- Fix the application name reported by the MSI noted at bug 274624 comment 15.
- The WIX file has a couple of GUID fields. As noted at ug 1475510 comment 8, Firefox opted to generate new GUIDs specifically for the MSI installer rather than reuse ones from the EXE installer. We need to generate some as well and update the WIX.

@mkmelkin: IIRC, you had told me the Vendor value in application.ini should be empty. Should that be the case here as well?
Thunderbird is building an MSI installer using the recently added support that
Firefox added.

The BrandFullname variable is hardcoded to "Firefox". This patch gets it from
buildconfig.
Yes, the Thunderbird vendor should be empty
Attachment #9033612 - Attachment is obsolete: true
Attachment 9033612 [details] didn't work out so well unfortunately since the buildconfig is no longer available when the repackage task For right now I've hardcoded the right values into our copy of installer.wxs.
Attachment #9033793 - Flags: review?(richard.marti)
Comment on attachment 9033793 [details] [diff] [review]
installer.wxs changes for Thunderbird

Review of attachment 9033793 [details] [diff] [review]:
-----------------------------------------------------------------

The Firefox Nightly MSI shows "Mozilla Firefox" and not "Nightly". So it's okay to hard code with Thunderbird and not to differ between the channels.

::: mail/installer/windows/msi/installer.wxs
@@ +5,5 @@
>  <!-- The version field only supports MSI version numbers, which cannot include
>       letters, and therefore cannot represent our version numbers. Set it to all
>       zeros to show it isn't valid, and add the real version to the Name. -->
> +<!-- For Thunderbird, the Manufacturer field (aka Vendor) is empty. -->
> +<Product Name="Thunderbird $(var.Version) $(var.Architecture) $(var.AB_CD)"

Name should be "Mozilla Thunderbird".
Attachment #9033793 - Flags: review?(richard.marti) → review+
Magnus, just for clarification. The "Vendor" field is empty, should the "Product Name" field be "Thunderbird" or "Mozilla Thunderbird"?
Flags: needinfo?(mkmelin+mozilla)
It should be $(var.BrandFullName) which is Mozilla Thunderbird. But I think you should rather fix whatever buildconfig bug there is that doesn't make var.BrandFullName be Firefox for us. If that's not working properly there is bound to be other subtle or non-subtle bugs around here.
Flags: needinfo?(mkmelin+mozilla)
Duplicate of this bug: 1539749

Making progress. Current issue from the WiX compiler:

With "Manufacturer" set to an empty string WiX produces:

error CNDL0006 : The Product/@Manufacturer attribute's value cannot be an empty string. If a value is not required, simply remove the entire attribute.

Removing the attribute produces:

error CNDL0010 : The Product/@Manufacturer attribute was not found; it is required.

This patch actually works and produces MSI files with the correct names.

That Manufacturer value has to be something apparently. An empty string yields an error, as does a string that's just a space. This makes it an *.

Built installers at
https://treeherder.mozilla.org/#/jobs?repo=try-comm-central&revision=ea16817c9fd7508323f0bd6e5fecf1f31f1bdb4a

It installed under Wine at least.

Attachment #9033793 - Attachment is obsolete: true
Attachment #9060989 - Flags: review?(richard.marti)
Comment on attachment 9060989 [details] [diff] [review]
finalize_msi.patch

LGTM and it installed under Win 7 with showing the correct name in title.
Attachment #9060989 - Flags: review?(richard.marti) → review+

Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/245790807d1f
Finalize MSI packaging for Thunderbird. r=Paenglab

Status: NEW → RESOLVED
Closed: 2 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 68.0

Suggestion for the Manufacturer field: use something like "The Thunderbird Team", if it actually appears anywhere.

You need to log in before you can comment on or make changes to this bug.