Closed Bug 1517128 Opened 2 years ago Closed 2 years ago

Intermittent leakcheck | gpu 24848 bytes leaked (APZUpdater, AsyncPanZoomController, CompositorManagerParent, CondVar, IAPZCTreeManager, ...)

Categories

(Core :: Panning and Zooming, defect, P5)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1465658

People

(Reporter: intermittent-bug-filer, Unassigned)

Details

(Keywords: intermittent-failure)

Filed by: apavel [at] mozilla.com

https://treeherder.mozilla.org/logviewer.html#?job_id=219499077&repo=try

https://queue.taskcluster.net/v1/task/SYMiOoHVT7qDp5qftiGR_Q/runs/0/artifacts/public/logs/live_backing.log

https://hg.mozilla.org/mozilla-central/raw-file/tip/layout/tools/reftest/reftest-analyzer.xhtml#logurl=https://queue.taskcluster.net/v1/task/SYMiOoHVT7qDp5qftiGR_Q/runs/0/artifacts/public/logs/live_backing.log&only_show_unexpected=1

12:43:54     INFO - TEST-START | /css/CSS2/borders/shand-border-001.xht
12:43:54     INFO - PID 8952 | 1546346634684	Marionette	INFO	Testing http://web-platform.test:8000/css/CSS2/borders/shand-border-001.xht == http://web-platform.test:8000/css/CSS2/reference/ref-if-there-is-no-red.xht
12:43:54     INFO - PID 8952 | ++DOMWINDOW == 109 (000002B2D8B60800) [pid = 6852] [serial = 1293] [outer = 000002B2D2D6AC00]
12:43:54     INFO - PID 8952 | 1546346634793	Marionette	INFO	No differences allowed
12:43:54     INFO - TEST-PASS | /css/CSS2/borders/shand-border-001.xht | took 153ms
12:43:54     INFO - PID 8952 | [GPU 8992, Compositor] WARNING: Possibly dropping task posted to updater thread: file z:/build/build/src/gfx/layers/apz/src/APZUpdater.cpp, line 370
12:43:54     INFO - PID 8952 | [GPU 8992, Compositor] WARNING: Possibly dropping task posted to updater thread: file z:/build/build/src/gfx/layers/apz/src/APZUpdater.cpp, line 370
12:43:54     INFO - PID 8952 | [Parent 8952, Gecko_IOThread] WARNING: pipe error: 109: file z:/build/build/src/ipc/chromium/src/chrome/common/ipc_channel_win.cc, line 332
12:43:54     INFO - PID 8952 | [Child 6852, Chrome_ChildThread] WARNING: pipe error: 109: file z:/build/build/src/ipc/chromium/src/chrome/common/ipc_channel_win.cc, line 332
12:43:56     INFO - nsTraceRefcnt::DumpStatistics: 185 entries
12:43:56     INFO - TEST-INFO | leakcheck | gpu leaked 1 APZUpdater
12:43:56     INFO - TEST-INFO | leakcheck | gpu leaked 2 AsyncPanZoomController
12:43:56     INFO - TEST-INFO | leakcheck | gpu leaked 2 CompositorManagerParent
12:43:56     INFO - TEST-INFO | leakcheck | gpu leaked 8 CondVar
12:43:56     INFO - TEST-INFO | leakcheck | gpu leaked 1 IAPZCTreeManager
12:43:56     INFO - TEST-INFO | leakcheck | gpu leaked 2 IPC::Channel
12:43:56     INFO - TEST-INFO | leakcheck | gpu leaked 2 ISurfaceAllocator
12:43:56     INFO - TEST-INFO | leakcheck | gpu leaked 1 InputQueue
12:43:56     INFO - TEST-INFO | leakcheck | gpu leaked 17 Mutex
12:43:56     INFO - TEST-INFO | leakcheck | gpu leaked 2 PCompositorBridgeParent
12:43:56     INFO - TEST-INFO | leakcheck | gpu leaked 2 PCompositorManagerParent
12:43:56     INFO - TEST-INFO | leakcheck | gpu leaked 2 RefCountedMonitor
12:43:56     INFO - TEST-INFO | leakcheck | gpu leaked 4 Runnable
12:43:56     INFO - TEST-INFO | leakcheck | gpu leaked 2 StoreRef
12:43:56     INFO - TEST-INFO | leakcheck | gpu leaked 2 WeakReference<PCompositorManagerParent
12:43:56     INFO - TEST-INFO | leakcheck | gpu leaked 1290 ZoomConstraints
12:43:56     INFO - TEST-INFO | leakcheck | gpu leaked 2 ipc::MessageChannel
12:43:56     INFO - TEST-INFO | leakcheck | gpu leaked 35 nsTArray_base
12:43:56     INFO - TEST-UNEXPECTED-FAIL | leakcheck | gpu 24848 bytes leaked (APZUpdater, AsyncPanZoomController, CompositorManagerParent, CondVar, IAPZCTreeManager, ...)
12:43:56     INFO - 
12:43:56     INFO - leakcheck | Processing leak log file c:\users\task_1546345560\appdata\local\temp\tmphuzg5h.mozrunner\runtests_leaks_7216_rdd_pid8936.log
12:43:56     INFO - 
12:43:56     INFO - == BloatView: ALL (cumulative) LEAK AND BLOAT STATISTICS, rdd process 8936
Seems another variant of bug 1515486.
Component: CSS Parsing and Computation → Panning and Zooming
See Also: → 1515486

Since everything else got duped to bug 1465658 let's dupe this one too.

Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
See Also: 1517357
Duplicate of bug: 1465658
You need to log in before you can comment on or make changes to this bug.