Closed Bug 1517212 Opened 2 years ago Closed 2 years ago

error: 'alloc_size' attribute ignored on a function returning 'int' [-Werror=attributes]

Categories

(Firefox Build System :: General, defect)

64 Branch
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1515287

People

(Reporter: jh, Assigned: jh)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:64.0) Gecko/20100101 Firefox/64.0

Steps to reproduce:

GCC 9 reports alloc-size warnings in libav:
/builds/worker/workspace/build/src/dom/media/platforms/ffmpeg/libav55/include/libavutil/mem.h:174:79: error: 'alloc_size' attribute ignored on a function returning 'int' [-Werror=attributes]
/builds/worker/workspace/build/src/dom/media/platforms/ffmpeg/ffmpeg58/include/libavutil/mem.h:342:79: error: 'alloc_size' attribute ignored on a function returning 'int' [-Werror=attributes]



Actual results:

It failed my build


Expected results:

It should have worked :)
Blocks: build-gcc-9
Component: Untriaged → General
Product: Firefox → Firefox Build System
Assignee: nobody → jh
Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1515287
You need to log in before you can comment on or make changes to this bug.