cannot download files to alternate drives if C: is full

VERIFIED DUPLICATE of bug 69938

Status

SeaMonkey
Download & File Handling
--
major
VERIFIED DUPLICATE of bug 69938
16 years ago
13 years ago

People

(Reporter: Kevin Cook, Assigned: Blake Ross)

Tracking

Trunk
x86
Windows 95

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
While trying to save a large file via the download manager to my E: drive
(because my C: drive is short on space), I receive an out-of-space error from
Windows after partial download with regards to my C: drive.  It seems that the
downloaded file is being written to c:/windows/temp first instead of directly to
the requested spot on E: (which has plenty of space).

Using 2002061108 on Win 95.

Comment 1

16 years ago
Probably a duplicate of Bug 55307 (which discusses basically the same problem: 
that downloading becomes impossible if there is no space available in the
cache/temp directory because of a disk running out of space, a quota being
reached, etc:  "you might not have enough space on the file system containing
the cache directory to download it there first and then move it to its final
location").
See also Bug 69938.

Comment 2

16 years ago
Resolving as dup of bug 69938. See also bug 55690.

*** This bug has been marked as a duplicate of 69938 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
AFAIK files start to download even before you select a destination and moved to
the selected destination after download is complete. 
Advantage: Downloading seems faster (you don't lose time, when selecting a dest.)
Problem: Files are stored in a temp-dir which leads to a bunch of probblems (
/tmp might be too small/slow, moving the file later might take a long time on
NFS etc)

Comment 4

16 years ago
vrfy dup
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.