Closed Bug 1517426 Opened 11 months ago Closed 11 months ago

YouTube full screen video turns black after a few seconds of playback with WebRender enabled

Categories

(Core :: Graphics: WebRender, defect, P2)

Unspecified
Windows
defect

Tracking

()

VERIFIED FIXED
mozilla66
Tracking Status
firefox-esr60 --- unaffected
firefox64 --- unaffected
firefox65 --- unaffected
firefox66 --- verified

People

(Reporter: cpeterson, Assigned: bholley)

References

(Blocks 1 open bug)

Details

(Keywords: regression)

STR:
1. Enable gfx.webrender.all
2. Play any YouTube video
3. Click the full screen video button while the video is playing

RESULT:
After about 5 seconds, the full screen video will go black but the audio will continue playing. If you move the mouse, the full screen video will return.

While the STR is simple, I can't reproduce this bug reliably. In my main profile on my Windows 10 laptop, I can reproduce this bug 100% of the time when gfx.webrender.all = true and never when gfx.webrender.all = false. But I can't reproduce the problem in a clean profile.

Could this bug be related to bug 1517117?
I think I saw a similar bug after bug 1516676 (bug 1505449) or bug 1516650 landed, but never again, so I didn't take it seriously.
this actually doesn't need to be full screen, but youtube's theater mode.
See Also: → 1517472
Win10, GTX1060
I just saw this bug while watching https://bug1517472.bmoattachments.org/attachment.cgi?id=9034178. The whole window got black after some seconds, until I moved my mouse. No crashes/warnings.
Keywords: regression
Priority: -- → P2
Click on the video link and wait a few seconds.
mozregression --good 2018-12-15 --bad 2019-01-02 --pref gfx.webrender.all:true -a https://bugzilla.mozilla.org/show_bug.cgi?id=1517426#c4
> 9:15.58 INFO: Last good revision: 605c950e275beac04b132e5613cc5e19d811e430
> 9:15.60 INFO: First bad revision: a3258a2824ab58f057efe68ab00e79fcddd1175f
> 9:15.60 INFO: Pushlog:
> https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=605c950e275beac04b132e5613cc5e19d811e430&tochange=a3258a2824ab58f057efe68ab00e79fcddd1175f

> a3258a2824ab	WR Updater Bot — Bug 1516676 - Update webrender to commit 8b8ca774f555aeb8ef99743196593a192298dd60 (WR PR #3452). r=kats
= https://github.com/servo/webrender/pull/3452
Blocks: 1516676
Flags: needinfo?(bobbyholley)
Lol, my guess in comment 2 was right. =)
I think I saw it on Twitter when scrolling down. The whole page was black for a tiny part of a second.
GitHub just had largely a black background when autoscrolling around. Not reproducible.
Doesn't happen with gfx.webrender.force-angle set to false.
I can reproduce this on windows. Investigating.
Assignee: nobody → bobbyholley
I have a simple fix that I ran by gw on IRC. I'm short on time this evening, and this fix is pretty safe, so I'm going to do the try push and GH landing in parallel.

https://treeherder.mozilla.org/#/jobs?repo=try&revision=03d1ca63ac5f9fc91b6a137c34ac105874f91eeb
Flags: needinfo?(bobbyholley)
I have the same issue with "gfx.webrender.all" on nightly/win10/nvidia. Youtube and some other videos.
Depends on: 1517910
Status: NEW → RESOLVED
Closed: 11 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla66
Flags: qe-verify+

I have managed to reproduce the issue only on Windows 10 machines with Intel HD Graphics 530 card and NVIDIA GeForce GTX 1050 using Firefox 66.0a1 20190103220533. The issue could not be reproduced on macOS or Ubuntu.

The issue is verified fixed on Fx66.0b13 on the mentioned machines. The youtube videos now play without turning the screen black anymore.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.