[Content Blocking][MAC 10.14] Wrong text color in "report a problem" subpanel for "URL" and "What problems .."

VERIFIED FIXED in Firefox 65

Status

()

defect
P3
normal
VERIFIED FIXED
6 months ago
5 months ago

People

(Reporter: adrian_sv, Assigned: dao, Mentored)

Tracking

(Blocks 2 bugs, {good-first-bug})

66 Branch
Firefox 66
Unspecified
macOS
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox64 unaffected, firefox65 verified, firefox66 verified)

Details

Attachments

(2 attachments)

Reporter

Description

6 months ago
Posted image black text.png
[Description:]

The text color for "URL" and "What problems did you have? (Optional)" is black, whereas is should be grey. (see attached Screenshot.)

This is an issue specific to OSX 10.14.2; it doesn't reproduced on 10.13.6;

[Environment:]
- 66.0a1 20190103094209
- 65.0b7 20181227144402

good - OSX 10.13.6
bad  - OSX 10.14.2
Mentor: jhofmann
Keywords: good-first-bug
Priority: -- → P3

Comment 2

5 months ago

:ntim

I think, this is a duplication of bug: 1515395
And this is OS dependent issue. That's why I was not able to see on my system.

Flags: needinfo?(ntim.bugs)

Updated

5 months ago
Duplicate of this bug: 1515395

Comment 4

5 months ago

(In reply to Manish [:manishkk] from comment #2)

:ntim

I think, this is a duplication of bug: 1515395
And this is OS dependent issue. That's why I was not able to see on my system.

All platforms have the color set to GrayText, it just turns out that macOS sets GrayText to a black color, while other platforms use gray. Either way, comment 1 describes how to fix this.

Flags: needinfo?(ntim.bugs)

Comment 5

5 months ago

Thanks for pointing out the duplicates, I've duped the other bug to this one.

Oh, I didn't realize, thanks for duping :)

Assignee

Comment 7

5 months ago

(In reply to Johann Hofmann [:johannh] from comment #1)

This line:

https://searchfox.org/mozilla-central/rev/76fe4bb385348d3f45bbebcf69ba8c7283dfcec7/browser/themes/shared/controlcenter/panel.inc.css#356

should be using color: var(--panel-disabled-color); instead of graytext.

As per bug 1520522, we shouldn't use var(--panel-disabled-color) here either.

Assignee

Updated

5 months ago
Assignee: nobody → dao+bmo
Status: NEW → ASSIGNED
Assignee

Updated

5 months ago
Blocks: 1520522

Comment 10

5 months ago
Pushed by dgottwald@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/053747e3a369
Stop using graytext for labels in the "report a problem" subpanel. r=johannh

Comment 11

5 months ago
bugherder
Status: ASSIGNED → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 66

Looks like a pretty safe ride-along polish fix for RC2. Please nominate this for release approval if you agree. It grafts cleanly.

Flags: qe-verify+
Flags: needinfo?(dao+bmo)

I verified this on Mac OS X 10.14 with Nightly 66.0a1 (2019-01-22) and I can confirm the fix.

Status: RESOLVED → VERIFIED
Assignee

Updated

5 months ago
Blocks: 1474238
Flags: needinfo?(dao+bmo)
Assignee

Comment 14

5 months ago

Comment on attachment 9037294 [details]
Bug 1517480 - Stop using graytext for labels in the "report a problem" subpanel. r=johannh

[Beta/Release Uplift Approval Request]

Feature/Bug causing the regression: bug 1474238

User impact if declined: see comment 0

Is this code covered by automated tests?: No

Has the fix been verified in Nightly?: Yes

Needs manual test from QE?: Yes

If yes, steps to reproduce:

List of other uplifts needed: -

Risk to taking this patch: Low

Why is the change risky/not risky? (and alternatives if risky): Simple UI change to avoid using graytext

String changes made/needed: -

Attachment #9037294 - Flags: approval-mozilla-beta?
Comment hidden (obsolete)

Comment on attachment 9037294 [details]
Bug 1517480 - Stop using graytext for labels in the "report a problem" subpanel. r=johannh

[Triage Comment]
Trivial UI polish fix. Approved for 65.0 RC2.

Attachment #9037294 - Flags: approval-mozilla-release?
Attachment #9037294 - Flags: approval-mozilla-release+
Attachment #9037294 - Flags: approval-mozilla-beta?

I verified on FF 65, Mac OS X 10.14 with the dark theme and I can confirm the fix.

Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.