Closed Bug 15175 Opened 20 years ago Closed 20 years ago

<auth> Proxy doesnt work

Categories

(Core :: Networking, defect, P3, major)

x86
Windows 98
defect

Tracking

()

VERIFIED DUPLICATE of bug 15927

People

(Reporter: Glenn.McGrath, Assigned: gagan)

Details

Hi, im on a network that requires a proxy configuration to get outside the lan.

Under advanced setup i set the autoproxy to my proxy setup, however i cant get
outside the lan.

Under netscape communicator and ie5 a dialog box pops up where i enter my proxy
username and password, but i dont get this with mozilla M9.

Im not sure wether this feature is supposed to work yet, i tried searching for
bugs relating to proxy but found none(maybe i didnt search correctly)

Unfortunatly i cant use mozilla untill it can work with a (my networks) proxy.

This is what i get from apprunner.exe maybe the error code means something to
you.

Doing Proxies startup...
Looking up prefwindow object...
Creating prefwindow object...
nsToolbarDragListener::MouseUp
FindShortcut: in='www.slashdot.org'  out='null'
Error: Can't load: http://www.slashdot.org/ (804b0001)
Error loading URL http://www.slashdot.org/
Document: Done (1.7 secs)
When i run ProxyTest.exe the text it spews out looks like its worked, but it
crashes, relevent info follows.
Im not familiour with how the proxy test works, so i cant judge if its a fair
test for my problem.

PROXYTEST caused an invalid page fault in
module PROXYTEST.EXE at 017f:00401228.
Registers:
EAX=000000a0 CS=017f EIP=00401228 EFLGS=00010206
EBX=007d6e50 SS=0187 ESP=00c6feb0 EBP=00c6feb4
ECX=007d6e50 DS=0187 ESI=007d6560 FS=2997
EDX=00402130 ES=0187 EDI=00797440 GS=0000
Bytes at CS:EIP:
8b 08 8d 55 0c 52 68 98 30 40 00 50 ff 11 8b 45
Stack dump:
007d6e50 00c6fec8 60a8f068 007d6e50 000000a0 007d6544 00c6ff4c 60a902b2
007d6e50 00000005 00000002 007d6520 00000000 007d6540 7800355d 609a18ee

Looping for events.
Spawn Threads:
        Thread (0) spawned
ProxyObjectManager: 797630
All Threads Spawned.

Wait for threads.
Thread (0) Join...
Deleting real Object (0)
Deleting real Object 2 (0)
Thread (0) Prior to calling proxyObject->Test.
Thread (1621684224) Test Called successfully! Party on...
Thread (0) error: 0.
Thread (0) Prior to calling proxyObject->Test2.
The quick brown netscape jumped over the old lazy ie..
Thread (0) error: 0.
Thread (0) Prior to calling proxyObject2->Test.
Thread (0) nsTestXPCFoo2::Test2() called successfully! Party on...
Thread (0) proxyObject2 error: 0.
Thread (0) Prior to calling proxyObject2->Test2.
nsTestXPCFoo2::Test2() called
Thread (0) proxyObject2 error: 0.
Deleting Proxy Object (0)
Deleting Proxy Object 2 (0)
The quick brown netscape jumped over the old lazy ie..
Thread (1) Test Called successfully! Party on...

1+2=3
sorry if this is the wrong bug. I can connect through a proxy set up using
workaround in bug#8559. However, viewer.exe still won't work, only apprunner. I
can open apprunner when viewer has failed and it amkes a connection jsut fine.
Vier returns this:
Error: Can't Load: http://mozilla.org/ (804b000d)
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → INVALID
viewer doesn't have proxy configurations set up since they come from
preferences. BTW proxytest is not a test for HTTP Proxies its for proxy events
across different threads. Marking this bug invalid then...
Status: RESOLVED → REOPENED
Please note original description as posted by Glenn.McGrath@jcu.edu.au.  This is
the correct problem description, and it is a bug for me as well.  Viewer and
proxytest are not part of the problem.
Resolution: INVALID → ---
Clearing INVALID resolution due to reopen of this bug.
Status: REOPENED → RESOLVED
Closed: 20 years ago20 years ago
Resolution: --- → DUPLICATE
ok thats a dup then...

*** This bug has been marked as a duplicate of 15927 ***
Bulk move of all Networking-Core (to be deleted component) bugs to new
Networking component.
Status: RESOLVED → VERIFIED
verified duplicate - 12/22/99
fixed summary (autoproxy is completely different!)
Summary: Auto Proxy doesnt work → <auth> Proxy doesnt work
You need to log in before you can comment on or make changes to this bug.