mail compaction fails while fetching mail

VERIFIED WORKSFORME

Status

VERIFIED WORKSFORME
17 years ago
10 years ago

People

(Reporter: dj, Assigned: naving)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.0.0) Gecko/20020530
BuildID:    2002053012

When MailNews starts up and is configured for fetching POP3 mail automatically,
the mailbox lock prevents the mailbox compaction process to complete. Side
effects are messages appearing "unread" although already read, appearance of the
"nstmp" directory with duplicate messages etc pp.

Reproducible: Sometimes
Steps to Reproduce:
1. configure a POP3 account to fetch mail automatically
2. start mailnews
3. have the inbox folder compacted

I used a folder structure when observing "messages marked unread after
compaction failure". The unrad messages seem to appear only within the user
folders, not within the "inbox" folder itself.

Comment 1

17 years ago
probably a dup -> Navin
Assignee: bienvenu → naving
Status: UNCONFIRMED → NEW
Component: Mail Database → Mail Back End
Ever confirmed: true

Updated

17 years ago
QA Contact: gayatri → sheelar
(Assignee)

Comment 2

17 years ago
I tried both ways Compacting while fetching mail and tried to fetch mail while
compacting and both of them behave as expected, i.e the operation started later
fails, and doesn't cause any nstemp folder to appear. I would suggest using
latest branch/trunk builds.

This is not a dup of the compact bug (because of fileTransport changes) because
build appears to be before that. 
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
QA Contact: sheelar → stephend
Verified.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.