Closed Bug 1517606 Opened 2 years ago Closed 2 years ago

Infinite loop in Bugzilla::Extension::BMO::_inject_headers_into_body()

Categories

(bugzilla.mozilla.org :: Extensions, defect)

Production
defect
Not set
critical

Tracking

()

RESOLVED FIXED

People

(Reporter: dylan, Assigned: dylan)

References

Details

Attachments

(2 files)

When Bugzilla::Extension::BMO::_inject_headers_into_body() gets an email with a 'X-Bugzilla-Changed-Fields' containing an unrecognized field, it enters an infinite loop. I have added a failing test case to extensions/BMO/t/inject_headers_into_body.t that triggers this. Still not sure how to fix it.
Attachment #9034310 - Attachment description: GitHub Pull Request → Change logic for extracting fields for 'headers in body' feature
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Duplicate of this bug: 1413016
Component: Extensions: SecureMail → Extensions
You need to log in before you can comment on or make changes to this bug.