Closed Bug 1517647 Opened 8 months ago Closed 3 months ago

compacting folders causes cpu load, and "Indexing messages: Determining which messages to index in Inbox"

Categories

(MailNews Core :: Database, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1406653

People

(Reporter: chaplain, Unassigned)

References

()

Details

(Keywords: perf, Whiteboard: [dupeme])

User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:60.0) Gecko/20100101 Firefox/60.0

Steps to reproduce:

Reply "yes" to query about compacting folders.  Running TB 60.4.0 32 bit on 64 bit Windows 7 SP1.


Actual results:

Folders appear to compact properly, but instead of returning to an idle thread condition the main process continues to run a core maximum duty cycle.  This "race" condition persists until the program is exited and restarted.
Perhaps a bad folder.
How many accounts?
Roughly how many folders?  (within +/- 100)
Component: Untriaged → Database
Flags: needinfo?(chaplain)
Keywords: perf
Product: Thunderbird → MailNews Core
And what % CPU is thunderbird.exe after compact is "done" - presumably when you see disk activity drop?
Ten accounts, roughly 200 folders.  Quad core runs 15 to 25% on TB process (60-100% on one core).  I run same profile on two different physical machines, but both are running the same configuration - same OS, TB versions.  Running numerous add-ons.

New info.  Wayne, your questions inspired me to check something new.  Activity Manager shows a magic wand and "Indexing messages: Determining which messages to index in Inbox".  No indication of any disk activity associated with indexing.
Flags: needinfo?(chaplain)

A quick note - Issue remains with TB 60.5.0 released this week.

Summary: compacting folders causes extended cpu loading → compacting folders causes cpu load, and "Indexing messages: Determining which messages to index in Inbox"
Whiteboard: [dupeme]
Version: 64 → 60

Additional information: For a while I suspected that this was caused by an Add-on that I didn't want to uninstall (and I hoped would be updated). That has now proved false.

The system still runs excessive clicks following a folder compaction. This continues until the application is closed. As I noted above (in comment 3), the Activity Manager also shows "Indexing messages: Determining which messages to index in Inbox".

Today, I stumbled across the Error Console in Developer Tools. I get the following message repeating once per second when this condition occurs: "2019-05-16 11:52:22 gloda.index_msg WARN Observed header that claims to be gloda indexed but that gloda has never heard of during compaction. In folder: mailbox://XXXXXXXXXXXX/Inbox sketchy key: XXXXXXXXX subject: XXXXXXXXXXXXX". Here the XXXXXXXXX strings indicate hidden characters of personal information.

Thus it appears that the code does not recover properly from this warning and just keeps repeating an attempt to compact this folder ad infinitum.

Thanks for reporting this. Let's continue in bug 1406653

Status: UNCONFIRMED → RESOLVED
Closed: 3 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1406653
You need to log in before you can comment on or make changes to this bug.