interactive version of tests with loopbackVideo fail

RESOLVED FIXED in Firefox -esr60

Status

task
RESOLVED FIXED
7 months ago
4 months ago

People

(Reporter: aryx, Assigned: dustin)

Tracking

unspecified
mozilla66

Firefox Tracking Flags

(firefox-esr60 fixed, firefox66 fixed)

Details

Attachments

(1 attachment)

Interactive tasks don't show the wizard once one connects anymore, |run-wizard| to launch it manually is not found. |mach| is also not found and connection to the screen of interactive browser-chrome tasks also fails. This was working on 2018-12-20.

Steps to reproduce:
1. Go to https://treeherder.mozilla.org/#/jobs?repo=try&searchStr=browser-chrome&revision=8d91b8dd6fcdfe9fd7a89b3232ea7a1bebc24396&selectedJob=219930209
2. In the bottom left, click the task ID: https://tools.taskcluster.net/tasks/BBSPDI3-RvKJbFd96Wv2lw
3. On the top right, sign in.
4. From the "Actions" menu, choose "Create Interactive Task".
5. Confirm the creation of the interactive task.
6. Open the "Actions" menu again and call "Create Interactive Task" which has moved to the "Built-In Actions" group now.
7. The page won't notify once the task is ready to connect to (bug 1515755), just reload the page.
8. Connect to the shell.
Expected result:
Wizard asking what user wants to do, see video at https://ahal.ca/blog/2016/taskcluster-interactive-loaner/
Actual result:
No wizard, shell with root folder active.
9. Connect to the screen.
Expected: Screen shown.
Actual: No screen for connection provided.
I am able to replicate. I don't think this is coming from the `taskcluster-tools` github repo. Dustin, any idea where this regression is coming from?
Flags: needinfo?(dustin)
> 4. From the "Actions" menu, choose "Create Interactive Task".
> 5. Confirm the creation of the interactive task.
> 6. Open the "Actions" menu again and call "Create Interactive Task" which has moved to the "Built-In Actions" group now.

This is the weird part -- why did you have to choose the action twice?  I *think* what has happened is that you've created an interactive task the "normal" way, then created an interactive version *of that interactive task*.  In the latter case, you see it under "Built-In Actions" because the in-tree taskgraph code doesn't support interactive tasks made from interactive tasks.

So I think the question is, what happens after step 5?
Flags: needinfo?(dustin)
Sorry, I rarely used it. After
> 5. Confirm the creation of the interactive task.
taskcluster reloads the page with the new action task.

Then a bc5-custom should be added, shouldn't it? There is none at https://treeherder.mozilla.org/#/jobs?repo=try&revision=8d91b8dd6fcdfe9fd7a89b3232ea7a1bebc24396&selectedJob=219930209

From the action task log:
[task 2019-01-04T14:51:59.678Z] Creating task with taskId e_7RnxJBQTeoAhbGmQuj0g for test-linux64/debug-mochitest-browser-chrome-e10s-5
[task 2019-01-04T14:52:01.714Z] Created interactive task e_7RnxJBQTeoAhbGmQuj0g; sending notification

https://tools.taskcluster.net/groups/HIHvCl5oR52ITdzVz5Dd9Q/tasks/e_7RnxJBQTeoAhbGmQuj0g/runs/0/logs/public%2Flogs%2Flive.log
[taskcluster 2019-01-04 14:53:13.579Z] Loading docker image from downloaded archive.
[taskcluster 2019-01-04 14:56:40.939Z] Image 'public/image.tar.zst' from task 'BAFbPjIUTOG8f9o0EEhahg' loaded.  Using image ID sha256:203384aff01e58b57cbe6958cef5deb95cfe849fc03129f43285a3daa8a6a08d.
[taskcluster:error] Docker configuration could not be created.  This may indicate an authentication error when validating scopes necessary for running the task. 
 Error: Insufficient scopes to attach devices to task container.  The task must have scope `docker-worker:capability:device:<dev-name>` for each device.
Ah, ok, so that's the error then.  I think that's because of the loopbackVideo device.
Component: Tools → Task Configuration
Product: Taskcluster → Firefox Build System
Summary: interactive tasks: run-wizard missing, no screen connections (interactive task setup broken?) → interactive version of tests with loopbackVideo fail
Assignee: nobody → dustin
Pushed by dmitchell@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/4658f4891f79
allow docker-worker:capability:device:*, too r=Callek
https://hg.mozilla.org/mozilla-central/rev/4658f4891f79
Status: NEW → RESOLVED
Closed: 7 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla66
You need to log in before you can comment on or make changes to this bug.