Closed Bug 151787 Opened 18 years ago Closed 18 years ago

NT-Server URLs without file:/ are handled incorrectly

Categories

(Core :: Networking: File, defect, minor)

x86
Windows 2000
defect
Not set
minor

Tracking

()

VERIFIED DUPLICATE of bug 66194

People

(Reporter: gjwucherpfennig, Assigned: dougt)

Details

(Whiteboard: DUPEME)

<html>
<head>
</head>
<body>
<a href="\\ntserver\path\file.doc">link</a>
</body>
</html>

In IE it works fine, but Mozilla adds this URL to the current location.
www.somewhere.com --> www.somewhere.com/\\ntserver\path\file.doc
That's not a properly formed URL... URLs aren't file paths.  It's a nonstandard
Microsoftism that such system-specific things work in MSIE; local files are
supposed to be accessed by "file:" URLs, and the backslashes changed to forward
slashes to suit the proper URL (URI) syntax.
.
Assignee: law → dougt
Component: File Handling → Networking: File
QA Contact: sairuh → benc
Whiteboard: DUPEME
The correct format for the link should be:
file://///ntserver/path/file.doc

*** This bug has been marked as a duplicate of 66194 ***
Status: UNCONFIRMED → RESOLVED
Closed: 18 years ago
Resolution: --- → DUPLICATE
URI fixup handles some use inputed \'s, but HREFS should have correct URLs.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.