Theme the splitters when the tree are themed

RESOLVED FIXED in Thunderbird 66.0

Status

enhancement
RESOLVED FIXED
5 months ago
a month ago

People

(Reporter: Paenglab, Assigned: Paenglab)

Tracking

unspecified
Thunderbird 66.0

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

Assignee

Description

5 months ago
Actually the splitters are hard coded and don't adapt with the themes. We can use the --sidebar-border-color variable for this.
Assignee

Comment 1

5 months ago
This adds to all splitters the --sidebar-border-color when existing.

I also fixed the conversation header on the top right of the chat where some lines aren't well visible in dark mode.

Lightning is untouched as I wait for bug 1504190.
Assignee: nobody → richard.marti
Status: NEW → ASSIGNED
Attachment #9034575 - Flags: review?(jorgk)
Assignee

Comment 2

5 months ago
This is my test theme. The splitters should be green.

Comment 3

5 months ago

Comment on attachment 9034575 [details] [diff] [review]
1517974-themed-splitters.patch

That theme gives sore eyes. CSS reviews are not my favourite. Yes, with the test theme lots of splitters are green now. Without the theme, things still look OK.

In chat, the splitter in the middle section:

22:15:59 - jorgk-testing-dont-talk-to-me has left the room (Quit: Client exited).
22:17:04 - jorgk-testing-dont-talk-to-me [Thunderbird@moz-h52gvk.dynamic.jazztel.es] entered the room.

---------- <=== this one
Let's type something here

Can only be moved up a little bit. There is space for about three lines. In TB 60 ESR it can be moved up a whole lot more. Is that a bug?

Attachment #9034575 - Flags: review?(jorgk) → review+
Assignee

Comment 4

5 months ago

Looks like a bug. Maybe from the textbox conversion to HTML.

Keywords: checkin-needed

Comment 5

5 months ago

Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/a9a6dd5c4e9f
Apply --sidebar-border-color to the splitters when we use themed trees. r=jorgk

Status: ASSIGNED → RESOLVED
Last Resolved: 5 months ago
Keywords: checkin-needed
Resolution: --- → FIXED

Updated

5 months ago
Target Milestone: --- → Thunderbird 66.0
Assignee

Updated

a month ago
Duplicate of this bug: 1545953
You need to log in before you can comment on or make changes to this bug.