Closed Bug 1517988 Opened 8 months ago Closed 8 months ago

"TypeError: aname is null" break about:support page when specific legacy add-ons is installed

Categories

(Toolkit :: General, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla66
Tracking Status
firefox66 --- fixed

People

(Reporter: yfdyh000, Assigned: aswan)

References

Details

Attachments

(2 files)

Case:
1. An old profile with specific legacy add-ons is installed. For me, it is gui:config, the 'a.name' got 'undefined'.
2. When I open about:support page, it shows empty form. Browser console says TypeError: aname is null  Troubleshoot.jsm:242:11.
I failed to install the add-on with old Firefox versions for reproduce.
Has Regression Range: --- → no
Has STR: --- → no

Andrew, this looks like a case of an old profile, and maybe the add-ons manager isn't giving about:support the right information, or possible about:support isn't handling it right.

Could your team take a look at it as the first diagnosis please?

Component: General → Add-ons Manager
Flags: needinfo?(aswan)
Product: Firefox → Toolkit

It looks like Troubleshoot.jsm wants to handle this but doesn't do it very well:
https://searchfox.org/mozilla-central/rev/5053031ba7621fa8f63f42de4c204ab3561e4e59/toolkit/modules/Troubleshoot.jsm#239-242

The expedient fix here is just to fix Troubleshoot.jsm to not fail in this case.

Component: Add-ons Manager → General
Flags: needinfo?(aswan)
Pushed by aswan@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/ab971e61cf79
Insert a placeholder name for addons if necessary in about:support r=Standard8
Status: NEW → RESOLVED
Closed: 8 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla66
See Also: → 1560746
You need to log in before you can comment on or make changes to this bug.