add words to US dictionary

RESOLVED FIXED in Firefox 66

Status

()

enhancement
RESOLVED FIXED
4 months ago
3 months ago

People

(Reporter: ananuti, Assigned: ananuti)

Tracking

(Blocks 1 bug)

Trunk
mozilla66
Points:
---

Firefox Tracking Flags

(firefox66 fixed)

Details

(Whiteboard: [Sheriff, please read comment 8])

User Story

biovular - bi + ovular = two separate ova; non-identical twins.

compressions - plural of compression.
‘Continuing CPR compressions until I have capture on the pacemaker.’

cystoscope,
cystoscopic,
cystoscopy - An instrument inserted into the urethra for examining the urinary bladder.
https://en.oxforddictionaries.com/definition/us/cystoscope
https://en.oxforddictionaries.com/definition/us/cystoscopic
https://en.oxforddictionaries.com/definition/us/cystoscopy

dizygotic,
dizygous - {fraternal, non-identical, dissimilar, biovular} twins.
https://en.oxforddictionaries.com/definition/us/dizygotic

et al - and others
‘the conclusions of Gardner et al’
https://en.oxforddictionaries.com/definition/us/et_al.

hooptie - (US) A car, especially an old or dilapidated one.
‘I can drive this hooptie.’
https://en.oxforddictionaries.com/definition/us/hooptie

monetization
https://en.oxforddictionaries.com/definition/us/monetization

monofilament - a single untwisted synthetic filament.
‘Get me three Teflon grafts and some monofilament sutures.’
https://en.oxforddictionaries.com/definition/us/monofilament

monovular - mono + ovular = the same ovum; identical.

monozygotic,
monozygous -  identical twins.
https://en.oxforddictionaries.com/definition/us/monozygotic

nutjob - a mentally unbalanced person : a crazy person.
‘The old Left would never have been a lackey for religious nutjobs.’
https://en.oxforddictionaries.com/definition/us/nutjob

paronychia - skin infection around the fingernails or toenails.
https://en.oxforddictionaries.com/definition/us/paronychia

polymorphically - In a polymorphic way; with varying or multiple manifestations.
https://en.oxforddictionaries.com/definition/us/polymorphically

polymorphism - The condition of occurring in several different forms.
https://en.oxforddictionaries.com/definition/us/polymorphism

thoracotomy - Surgical incision into the chest wall.
‘We need to do an open thoracotomy now.’
https://en.oxforddictionaries.com/definition/us/thoracotomy

ulcerative - the process of becoming ulcerated : the state of being ulcerated.
‘Other risk factors include asthma, cirrhosis, diabetes, and ulcerative colitis.’
https://en.oxforddictionaries.com/definition/us/ulcerative

utero e.g. in utero - occurring in womb, uterus.
‘males are more susceptible than females to die in utero.’
https://en.oxforddictionaries.com/definition/us/in_utero

Attachments

(1 attachment, 1 obsolete attachment)

Comment hidden (empty)
(Assignee)

Updated

4 months ago
Crash Signature: biovular - bi + ovular = two separate ova; non-identical twins. compressions - plural of compression. ‘Continuing CPR compressions until I have capture on the pacemaker.’ cystoscope, cystoscopic, cystoscopy - An instrument inserted into the ureth…
User Story: (updated)
(Assignee)

Comment 1

4 months ago
Posted patch bug1518008.patch (obsolete) — Splinter Review
Attachment #9034600 - Flags: review?(ehsan)
(Assignee)

Comment 2

4 months ago
NOTE: Again, unfortunately, the patch is unsafe for sheriff to land using |hg qimport bz://1518008|. (bug 646098)

Comment 3

4 months ago
Comment on attachment 9034600 [details] [diff] [review]
bug1518008.patch

Review of attachment 9034600 [details] [diff] [review]:
-----------------------------------------------------------------

http://app.aspell.net/lookup recommends against including biovular, monovular, and hooptie since they're really uncommon words.  I tend to agree with that recommendation since the bi- and mono- prefixes as well as the -ie suffix (which are rather common) will run the risk of suggesting these uncommon words as spelling recommendations for more common words.

Do you mind dropping these three please?  Thanks!
Attachment #9034600 - Flags: review?(ehsan) → review-
(Assignee)

Updated

4 months ago
Blocks: 499593
User Story: (updated)
(Assignee)

Comment 4

4 months ago

(In reply to :Ehsan Akhgari from comment #3)

Do you mind dropping these three please? Thanks!

i don't. :)

(Assignee)

Comment 5

4 months ago
  • drop biovular, monovular, and hooptie
  • add Kubernetes, et al, nutjob
Attachment #9034600 - Attachment is obsolete: true
Attachment #9034874 - Flags: review?(ehsan)
(Assignee)

Updated

4 months ago
Duplicate of this bug: 1517866

Comment 7

4 months ago
Comment on attachment 9034874 [details] [diff] [review]
bug1518008(1).patch

Review of attachment 9034874 [details] [diff] [review]:
-----------------------------------------------------------------

::: extensions/spellcheck/locales/en-US/hunspell/en-US.dic
@@ +6889,5 @@
>  Krystal/M
>  Krystyna/M
>  Kshatriya/M
>  Kuala/M
> +Kubernetes/M

Nice!
Attachment #9034874 - Flags: review?(ehsan) → review+
(Assignee)

Comment 8

4 months ago

Sheriff, the patch will become corrupted if you pull with |hg qimport bz://1518008|. Please download and apply the patch manually. Thanks.

Keywords: checkin-needed
Whiteboard: [Sheriff, please read comment 8]

Comment 9

3 months ago
Keywords: checkin-needed

Comment 10

3 months ago
bugherder
Status: NEW → RESOLVED
Last Resolved: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla66
You need to log in before you can comment on or make changes to this bug.