Copying "only this" recurring calendar event results in recurring field disabled (has RECURRENCE-ID, but no RRULE)

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
3 months ago
a month ago

People

(Reporter: newluck77, Unassigned, NeedInfo)

Tracking

Lightning 6.2.4
x86_64
Windows 10

Details

Attachments

(2 attachments)

(Reporter)

Description

3 months ago
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:64.0) Gecko/20100101 Firefox/64.0

Steps to reproduce:

1. Create recurring calendar event (weekly)
2. Copy "only this event" (rather than "all events")
3. `VEVENT`'s `RRULE` `FREQ=WEEKLY` changes to `FREQ=YEARLY`
4. Paste into any calendar
5. Recurring field is disabled/greyed out in the editor

To clarify: The problem already occurs at copying, which can be seen in the plain text examples below.


Actual results:

As you can see below, the `RRULE` of the `VEVENT` changes to `FREQ=YEARLY`

```
BEGIN:VCALENDAR
PRODID:-//Mozilla.org/NONSGML Mozilla Calendar V1.1//EN
VERSION:2.0
BEGIN:VTIMEZONE
TZID:Europe/Vienna
BEGIN:DAYLIGHT
TZOFFSETFROM:+0100
TZOFFSETTO:+0200
TZNAME:CEST
DTSTART:19700329T020000
RRULE:FREQ=YEARLY;BYDAY=-1SU;BYMONTH=3
END:DAYLIGHT
BEGIN:STANDARD
TZOFFSETFROM:+0200
TZOFFSETTO:+0100
TZNAME:CET
DTSTART:19701025T030000
RRULE:FREQ=YEARLY;BYDAY=-1SU;BYMONTH=10
END:STANDARD
END:VTIMEZONE
BEGIN:VEVENT
CREATED:20190106T143716Z
LAST-MODIFIED:20190106T143716Z
DTSTAMP:20190106T143716Z
UID:8cddcaad-bf91-40be-ab21-159a55404e50
SUMMARY:Test_copy_all
RECURRENCE-ID;TZID=Europe/Vienna:20190215T160000
DTSTART;TZID=Europe/Vienna:20190215T160000
DTEND;TZID=Europe/Vienna:20190215T170000
TRANSP:OPAQUE
END:VEVENT
END:VCALENDAR
```

In comparison, when I "copy all events":

```
BEGIN:VCALENDAR
PRODID:-//Mozilla.org/NONSGML Mozilla Calendar V1.1//EN
VERSION:2.0
BEGIN:VTIMEZONE
TZID:Europe/Vienna
BEGIN:DAYLIGHT
TZOFFSETFROM:+0100
TZOFFSETTO:+0200
TZNAME:CEST
DTSTART:19700329T020000
RRULE:FREQ=YEARLY;BYDAY=-1SU;BYMONTH=3
END:DAYLIGHT
BEGIN:STANDARD
TZOFFSETFROM:+0200
TZOFFSETTO:+0100
TZNAME:CET
DTSTART:19701025T030000
RRULE:FREQ=YEARLY;BYDAY=-1SU;BYMONTH=10
END:STANDARD
END:VTIMEZONE
BEGIN:VEVENT
CREATED:20190106T143701Z
LAST-MODIFIED:20190106T143716Z
DTSTAMP:20190106T143716Z
UID:8cddcaad-bf91-40be-ab21-159a55404e50
SUMMARY:Test_copy_only_this
RRULE:FREQ=WEEKLY
DTSTART;TZID=Europe/Vienna:20190215T160000
DTEND;TZID=Europe/Vienna:20190215T170000
TRANSP:OPAQUE
END:VEVENT
END:VCALENDAR
```

___

PS.: After copying the spinning wheel cursor appears and doesn't go away until closing and reopening Thunderbird. Editing the broken calendar event results in the spinning wheel cursor again.


Expected results:

If I "only copy this", I expect 

- calendar event to be copied without an `RRULE`
- recurring field in editor to be editable
(Reporter)

Updated

3 months ago
OS: Unspecified → Windows 10
Hardware: Unspecified → x86
(Reporter)

Updated

3 months ago
Hardware: x86 → x86_64
(Reporter)

Updated

3 months ago
Summary: Copying "only this" recurring calendar event results in recurring field disabled and "weekly" changes to "yearly" → Copying "only this" recurring calendar event results in recurring field disabled (has RECURRENCE-ID, but no RRULE)
(Reporter)

Comment 1

3 months ago
***Unfortunately I cannot edit the User Story above*** (the respective area is empty/blank).

I was mistaken. The `RRULE` is removed just fine. The copied event keeps its `RECURRENCE-ID` though. I think that the error lies there.
(Reporter)

Comment 2

3 months ago
It seems I cannot edit anything here. Seems that "User Story" is a different concept. I simply wanted to edit my first post, which apparently I can't. Thus I created more noise than I wanted.

Comment 3

a month ago

Works as expected. The recurrence information is disabled on purpose if you open an occurrence. If you want to edit the recurrence rule, open the master event. Given that you already noticed that the rrule part of your report was invalid, I'm going resolve this bug.

As a regular user, you cannot edit bugzilla repots or comments.

Status: UNCONFIRMED → RESOLVED
Last Resolved: a month ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 4

a month ago

Seems, you didn't read my later comments properly.

The RECURRENCE-ID should be cleared too, but it isn't - resulting in the behaviour described above.

The copied event should not be part of the original recurring event because I want to make a new recurring rule, which is not tied to the original recurring event.

(Reporter)

Comment 5

a month ago

Oh, and the spinning cursor is annoying, of course. Don't you have it?

Updated

a month ago
Flags: needinfo?(makemyday)
(Reporter)

Comment 6

a month ago

And another glitch. When I go to "Search events", I have empty entries in the list (they don't show up in the calendar view and don't have any meaning. They start on a date where I have copied a single instance of a recurring event to.)

I'll attach another screenshot.

You need to log in before you can comment on or make changes to this bug.