[RTL] Awesomebar dropdown items are messed up

RESOLVED FIXED in Firefox 66

Status

()

defect
P1
normal
RESOLVED FIXED
5 months ago
5 months ago

People

(Reporter: itiel_yn8, Assigned: dao)

Tracking

({regression, rtl})

unspecified
Firefox 66
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr60 unaffected, firefox64 unaffected, firefox65 unaffected, firefox66+ fixed)

Details

Attachments

(2 attachments)

Reporter

Description

5 months ago
Posted image Screenshot
This is a regression caused by bug 1516533.

STR is to set Nightly to RTL (intl.uidirection = 1), restart and open several websites (preferably with long URLs and titles). Open the awesomebar popup and see the entries there.
Some URLs will be overlapped with their title, and some items will have their URL/title shortened.

See screenshot.
Reporter

Updated

5 months ago
Has Regression Range: --- → yes
Has STR: --- → yes
Flags: needinfo?(dao+bmo)
Assignee

Updated

5 months ago
Assignee: nobody → dao+bmo
Status: NEW → ASSIGNED
Flags: needinfo?(dao+bmo)
Priority: -- → P1
Reporter

Comment 2

5 months ago
(In reply to Dão Gottwald [::dao] from comment #1)
> Created attachment 9034660 [details]
> Bug 1518024 - Go back to setting style.direction on the awesomebar popup
> because automplete.xml expects this. r=mak

I guess there's a typo there and you actually meant autocomplete.xml?

Comment 3

5 months ago
Pushed by dgottwald@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/76c4b7d2ae72
Go back to setting style.direction on the awesomebar popup because automplete.xml expects this. r=mak

Comment 4

5 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/76c4b7d2ae72
Status: ASSIGNED → RESOLVED
Last Resolved: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 66
You need to log in before you can comment on or make changes to this bug.