Closed Bug 1518094 Opened 9 months ago Closed 8 months ago

Intermittent toolkit/components/passwordmgr/test/mochitest/test_basic_form_autocomplete.html with 14 fails

Categories

(Toolkit :: Password Manager, defect, P1)

defect

Tracking

()

RESOLVED FIXED
mozilla66
Tracking Status
firefox66 --- fixed

People

(Reporter: vinoth, Assigned: MattN)

References

Details

Attachments

(1 file)

toolkit/components/passwordmgr/test/mochitest/test_basic_form_autocomplete.html test fails everytime locally(Mac OS) regardless of making any changes.

ERROR LOG:

0:07.02 GECKO(96166) JavaScript error: file:///Users/vinothkumar/src2/mozilla-central/obj-x86_64-apple-darwin18.0.0/dist/Nightly.app/Contents/Resources/components/storage-json.js, line 444: TypeError: login is null
 0:07.02 GECKO(96166) JavaScript error: file:///Users/vinothkumar/src2/mozilla-central/obj-x86_64-apple-darwin18.0.0/dist/Nightly.app/Contents/Resources/components/nsLoginManager.js, line 347: NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS: [JavaScript Error: "login is null" {file: "file:///Users/vinothkumar/src2/mozilla-central/obj-x86_64-apple-darwin18.0.0/dist/Nightly.app/Contents/Resources/components/storage-json.js" line: 444}]'[JavaScript Error: "login is null" {file: "file:///Users/vinothkumar/src2/mozilla-central/obj-x86_64-apple-darwin18.0.0/dist/Nightly.app/Contents/Resources/components/storage-json.js" line: 444}]' when calling method: [nsILoginManagerStorage::removeLogin]
 0:07.02 GECKO(96166) JavaScript error: file:///Users/vinothkumar/src2/mozilla-central/obj-x86_64-apple-darwin18.0.0/dist/Nightly.app/Contents/Resources/components/nsLoginManager.js, line 347: NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS: [JavaScript Error: "login is null" {file: "file:///Users/vinothkumar/src2/mozilla-central/obj-x86_64-apple-darwin18.0.0/dist/Nightly.app/Contents/Resources/components/storage-json.js" line: 444}]'[JavaScript Error: "login is null" {file: "file:///Users/vinothkumar/src2/mozilla-central/obj-x86_64-apple-darwin18.0.0/dist/Nightly.app/Contents/Resources/components/storage-json.js" line: 444}]' when calling method: [nsILoginManagerStorage::removeLogin]
 0:07.02 INFO AddTask.js | Leaving test test_form1_check_only_entry_remaining
 0:07.02 INFO AddTask.js | Entering test test_form2
 0:07.02 FAIL Checking form2 username is: singleuser5 - got "", expected "singleuser5"
    SimpleTest.is@SimpleTest/SimpleTest.js:320:5
    checkACForm@toolkit/components/passwordmgr/test/mochitest/test_basic_form_autocomplete.html:195:3
    test_form2@toolkit/components/passwordmgr/test/mochitest/test_basic_form_autocomplete.html:575:3
    async*nextTick/<@SimpleTest/AddTask.js:70:34
    async*nextTick@SimpleTest/AddTask.js:44:10
    setTimeout handler*SimpleTest_setTimeoutShim@SimpleTest/SimpleTest.js:684:12
    add_task@SimpleTest/AddTask.js:30:7
    @toolkit/components/passwordmgr/test/mochitest/test_basic_form_autocomplete.html:209:1
 0:07.02 FAIL Checking form2 password is: singlepass5 - got "", expected "singlepass5"
    SimpleTest.is@SimpleTest/SimpleTest.js:320:5
    checkACForm@toolkit/components/passwordmgr/test/mochitest/test_basic_form_autocomplete.html:196:3
    test_form2@toolkit/components/passwordmgr/test/mochitest/test_basic_form_autocomplete.html:575:3
    async*nextTick/<@SimpleTest/AddTask.js:70:34
    async*nextTick@SimpleTest/AddTask.js:44:10
    setTimeout handler*SimpleTest_setTimeoutShim@SimpleTest/SimpleTest.js:684:12
    add_task@SimpleTest/AddTask.js:30:7
    @toolkit/components/passwordmgr/test/mochitest/test_basic_form_autocomplete.html:209:1

Hmm… I haven't seen any other reports of this and we don't have automatic failures in automation on macOS either. What command are you using to see this test fail?

Flags: needinfo?(cegvinoth)
Priority: -- → P5

(In reply to Matthew N. [:MattN] (PM me if requests are blocking you) from comment #1)

Hmm… I haven't seen any other reports of this and we don't have automatic failures in automation on macOS either. What command are you using to see this test fail?

I am using this command,
./mach mochitest toolkit/components/passwordmgr/test/mochitest/test_basic_form_autocomplete.html

Correct me if I need to use something else.

Flags: needinfo?(cegvinoth)

It seems like there is a race with setting prefs like signon.autofillForms.http=true

Assignee: nobody → MattN+bmo
Status: NEW → ASSIGNED
Priority: P5 → P1

Move prefs from pwmgr_common.js to mochitest.ini and remove redundant calls to set those same prefs.

Pushed by jwein@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/44d70ce90650
Fix test_*_autocomplete.html autofill failures by setting prefs sooner. r=jaws
Status: ASSIGNED → RESOLVED
Closed: 8 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla66
Duplicate of this bug: 1521077
Duplicate of this bug: 1519252
You need to log in before you can comment on or make changes to this bug.