RFE: disable Connection Refused dialog for hosts that map to 0.0.0.0

VERIFIED WORKSFORME

Status

()

Core
Networking
--
enhancement
VERIFIED WORKSFORME
16 years ago
15 years ago

People

(Reporter: Pete Flugstad, Unassigned)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
I run with a hosts file from http://www.smartin-designs.com/.  
This maps many the hostnames of many (13,000+) of the ad, image 
and banner servers to either 127.0.0.1 or 0.0.0.0.   I generally
do this on my Windoze box, but I've done it on Linux as well.

In older versions of Mozilla (pre 0.9.8 I think), if I used the 
mapping to 0.0.0.0, Mozilla would see that and silently go on
it's way, ignoring the error.  

In 0.9.8 and later however, it started putting up "Connection
Refused" dialog boxes for every one of these.  This got really
annoying really FAST, so I had to remove these mappings.

Would it be possible to put hooks in so that if Mozilla's name
resolver finds a host name mapping to 0.0.0.0, it skips the
dialog box and just goes on?

Thanks
Pete Flugstad
(Reporter)

Updated

16 years ago
Severity: normal → enhancement

Updated

16 years ago
Whiteboard: dupeme

Comment 1

16 years ago
I created my bugzilla account JUST so I could vote for this bug.  I use and am a
big fan of Pete's hosts file, and since I started using Mozilla 1.0 I've had to
change my configuration.

The sheer number of host errors generated made me realize HOW MANY websites are
using less than scrupulous techniques to track their web readers.  Supporting
0.0.0.0 hosts is a life (and privacy) saver!

I will attempt a patch for this if no one else does.

Comment 2

16 years ago
hi, for this http://bugzilla.mozilla.org/show_bug.cgi?id=25618 has been opened,
I think this is a dupe of Bug 25618

Comment 3

15 years ago
-> DOCSHELL
Component: Networking → Embedding: Docshell

Comment 4

15 years ago
.
Assignee: new-network-bugs → adamlock
QA Contact: benc → adamlock

Comment 5

15 years ago
-> Networking
Assignee: adamlock → new-network-bugs
Component: Embedding: Docshell → Networking
QA Contact: adamlock → benc

Comment 6

15 years ago
-> sent to networking eng.
Keywords: helpwanted
Whiteboard: dupeme

Comment 7

15 years ago
I belive that I am exeriencing the same bug on (Mozilla 0.9.9 -- Mozilla/5.0
(X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020408) .. under RedHat 7.3 I
telnet to a colleague's box and run Mozilla from his workstation on a site that
is running under User Mode Linux on his box. His box might is 192.168.0.119, and
the user Mode Linux is 192.168.1.119.

If I try to get in by name (as specified in /etc/hosts) to the USer Mode Linux,
Mozilla fails. If I try to get in by IP number I get the "Connection Refused" error.

The same thing works fine using Netscape (and Lynx, and telnetting into the IP
address -- hence I suspect Mozilla). I have to make this application work for
various flavours of browsers, and I'd like to include Mozilla. Look forward to
hearing from you about this.

Thanks!
Alex Beamish

Comment 8

15 years ago
It sure looks like this bug was caused by the fix for bug 20445.

In the change to docshell/base/nsWebShell.cpp from 1.372 to 1.373, 
a check was added to throw a dialog for "connection refused" returns.

You proably want a dialog if an enclosing html document gets refused,
but you probably don't want a dialog if some embedded element like
an image gets refused.  It will show up with the "broken box" icon
anyway.

(Reporter)

Comment 9

15 years ago
Note: as of Mozilla 1.1 on Win2k, I am not seeing this anymore.
I don't know what changed or when (I actually think it's been
"fixed" for a while now) but it got fixed somehow.  I now just 
get the broken icons like I used to, no more connection refused
dialogs.

Pete Flugstad

Comment 10

15 years ago
Certain error messages including connection refused are supressed in (i)frames
which may explain why you don't see it anymore.

Comment 11

15 years ago
reporter says wfm 
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME

Comment 12

15 years ago
verified. 
Status: RESOLVED → VERIFIED
Keywords: helpwanted
You need to log in before you can comment on or make changes to this bug.