DevTools XUL searchboxes look broken

VERIFIED FIXED in Firefox 65

Status

defect
P2
normal
VERIFIED FIXED
5 months ago
4 months ago

People

(Reporter: ntim, Assigned: ntim)

Tracking

(Blocks 1 bug, {regression})

unspecified
Firefox 66
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr60 unaffected, firefox64 wontfix, firefox65 verified, firefox66 verified)

Details

Attachments

(2 attachments)

Assignee

Description

5 months ago
No description provided.
Assignee

Updated

5 months ago
Component: Storage Inspector → Framework
Summary: Storage inspector searchbox looks broken → DevTools XUL searchbox look broken
Assignee

Updated

5 months ago
Summary: DevTools XUL searchbox look broken → DevTools XUL searchboxess look broken
Assignee

Updated

5 months ago
Summary: DevTools XUL searchboxess look broken → DevTools XUL searchboxes look broken
Assignee

Comment 1

5 months ago
The issue is caused by bug 1473927 which increased the specificity of the toolkit textbox[type=search] rules.

Since no-one is maintaining the DevTools XUL panels (hence having this bug slip in 3 releases), I think it's just more simple to stop using [type=search], and remove the associated DevTools styling.
Assignee

Comment 3

5 months ago
Note that the only side-effects of not using textbox[type=search] are simply:
- No built-in clear button
- No "timeout" feature (waiting for the 200/500ms timeout to pass before actually searching)
Assignee

Updated

5 months ago
Blocks: 1518142
Priority: -- → P2

Comment 4

5 months ago
Pushed by ntim.bugs@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/aab09dc65108
Remove usages of and support for XUL textbox[type='search'] in DevTools. r=pbro
Assignee

Comment 5

5 months ago

Comment on attachment 9034751 [details]
Bug 1518159 - Remove usages of and support for XUL textbox[type='search'] in DevTools. r=pbro

[Beta/Release Uplift Approval Request]

Feature/Bug causing the regression: Bug 1473927

User impact if declined: See attachment 9034747 [details]

Is this code covered by automated tests?: No

Has the fix been verified in Nightly?: No

Needs manual test from QE?: Yes

If yes, steps to reproduce: See attachment 9034747 [details]

List of other uplifts needed: None

Risk to taking this patch: Low

Why is the change risky/not risky? (and alternatives if risky): Trivial change, though comes with a approved small feature loss

String changes made/needed: none

Attachment #9034751 - Flags: approval-mozilla-beta?

Comment 6

5 months ago
bugherder
Status: NEW → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 66
Flags: qe-verify+

Comment on attachment 9034751 [details]
Bug 1518159 - Remove usages of and support for XUL textbox[type='search'] in DevTools. r=pbro

[Triage Comment]
Removes the use of a feature that isn't well-supported and regressed in Fx64. Might as well take it now for Fx65 rather than letting it be broken in another release before the removal ships with 66. Approved for 65.0b10.

Attachment #9034751 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

Verified the fix with 66.0a1 (2019-01-10) on Windows 10, macOS 10.13, Ubuntu 16.04.
65.0b9 indeed appears to still be affected by styling issues.

Status: RESOLVED → VERIFIED

Fix confirmed for 65.0b10 as well.

Flags: qe-verify+
Assignee

Updated

4 months ago
Duplicate of this bug: 1504697
Assignee

Updated

4 months ago
Blocks: 1504697
You need to log in before you can comment on or make changes to this bug.